Opened 7 months ago

Closed 5 months ago

Last modified 3 months ago

#12089 closed Bug report (fixed)

SFTP broken after version 3.46.0

Reported by: BB Owned by:
Priority: normal Component: FileZilla Client
Keywords: sftp Cc:
Component version: 3.46.3 Operating system type: Windows
Operating system version: 1903

Description

Can't use SFTP on any version after 3.20.1 to the Lenovo ix2-dl NAS.

Status:	Connecting to xxx.ddns.net:1977...
Response:	fzSftp started, protocol_version=9
Command:	open "ftp@xxx.ddns.net" 1977
Command:	Pass: ********
Error:	FATAL ERROR: Remote side sent disconnect message
Error:	type 11 (by application):
Error:	"Unsupported protocol sequence"
Error:	Could not connect to server

Note: 1977 port is forwarded to 22 on router.

Works fine with 3.20.1 and below. Also tested with latest versions of other ftp clients such as CyberDuck and FireFTP and they work fine.

Change History (32)

comment:1 by BB, 7 months ago

Cant modify ticket. SFTP works in version 3.46.0 and below.

Last edited 7 months ago by BB (previous) (diff)

comment:2 by mamamio, 7 months ago

Same problem here on new version 3.46.3. Some sftp-accounts work, others do not work. If I switch to a computer with an older version (3.45.1) all sftp-accounts work without problem.

Fehler:	FATAL ERROR: Remote side sent disconnect message
Fehler:	type 11 (by application):
Fehler:	"Unsupported protocol sequence"
Fehler:	Herstellen der Verbindung zum Server fehlgeschlagen

comment:3 by Tim Kosse, 7 months ago

Status: newmoreinfo

Which SSH server software (product and version) are you running on the server?

comment:4 by mamamio, 7 months ago

Status: moreinfonew

Hi Tim, I am not sure how I can find out about the server software. The SFTP-server is operated by a customer.

comment:5 by BB, 7 months ago

Looks like its to do with the update in 3.46.1.

- SFTP components have been updated and are now based on PuTTY 0.73

Doesn't really help if we don't have access to SSH server to update or whatever.

Last edited 7 months ago by BB (previous) (diff)

comment:6 by mamamio, 7 months ago

@Bassquake/BB: can you help out with a test sftp-server?

comment:7 by BB, 7 months ago

What do I need to do?

comment:8 by mamamio, 7 months ago

Hi BB, I am just wondering if you can provide details about your SFTP-server that does not work with the lastest FileZilla version (name and version), eventually even provide access to a test-account so that Tim can perform a test and hopefully find the problem. It seems that some SFTP-servers work with versions 3.41.3 and other SFTP-servers don't like FileZilla any more...

comment:9 by BB, 7 months ago

Oh I see. I'm accessing my NAS. A Lenovo ix2-dl which has SFTP service running. Doesn't really give any information on version or anything.

Might be some useful info here: https://download.lenovo.com/lenovoemc/na/en/app/cust_alp/p/1189,1199.html

I'll look into setting up a sftp test account.

comment:10 by Tim Kosse, 7 months ago

Status: newmoreinfo

Contact your server administrator or server hosting provider for assistance to inquire no the used SSH server software (product and version).

comment:11 by BB, 7 months ago

Status: moreinfonew

Ok. I got SSH access to the NAS and did the command:

root@NAS:/# ssh -v localhost

The result is:

OpenSSH_7.8p1, OpenSSL 1.0.2o  27 Mar 2018

Hope that helps!

comment:12 by Tim Kosse, 7 months ago

Status: newmoreinfo

That is odd, there are no known compatibility issues with OpenSSH 7.8p1 and also the server-provided string "Unsupported protocol sequence" is not present in OpenSSH.

Are you certain that OpenSSH is responsible for the SSH server on port 1977?

comment:13 by BB, 7 months ago

Status: moreinfonew

I'm connecting locally through port 22.

Is there a different command I can try to verify SFTP version or something else?

comment:14 by BB, 7 months ago

In interactive mode, I did:

sftp> version

Result is:

SFTP protocol version 3

If thats any use?

comment:15 by Leon Blackwell, 6 months ago

I'm seeing the same timeout behaviour in 3.46.3 (but not in 3.46.0 or older):

Remote protocol version 2.0, remote software version OpenSSH_7.6p1 Ubuntu-4ubuntu0.3

comment:16 by BB, 6 months ago

Summary: SFTP broken after version 3.20.1SFTP broken after version 3.46.0

Modified ticket title to correct version

comment:17 by Yannick, 6 months ago

Hi,

We are also experiencing issues with Filezilla >3.46 over SFTP. We make use of ProFTPD v1.3.6rc4 on OmniOS with mod_sftp for SFTP support.

When we start an upload it eventually times out, on 3.45.1 we don't experience this. We have tested this both on clients running Windows 7 and Windows 10, both experience problems.

comment:18 by Tim Kosse, 6 months ago

Status: newmoreinfo

That is an outdated version of ProFTPD. Do you still experience this issue if updating to the most recent version of ProFTPD?

comment:19 by Yannick, 6 months ago

Status: moreinfonew

Hi Tim,

When using Filezilla 3.46.3 on Linux with Proftpd 1.3.6-4 (the version shipped with Debian Buster, latest stable) I also experience the timeout issue.

Something interesting to note is that the timeout only seems to occur with larger files. A ~444MB file takes a little while to start but eventually gets going. A smaller file, ~35MB gets going pretty much instantly. While a ~2GB file takes a really long time to start and with a ~4G file I run into the timeout issue.

This behaviour does not occur when I use v3.45.1, file transfers start instantly, regardless of the file size.

Would it be of any help if I provide you with a set of credentials so you can test it yourself?

comment:20 by Tim Kosse, 6 months ago

Status: newmoreinfo

Would it be of any help if I provide you with a set of credentials so you can test it yourself?

Yes, doesn't hurt. Can give you a more detailed analysis of what is wrong with your server.

in reply to:  20 comment:21 by Yannick, 6 months ago

Status: moreinfonew

Replying to Tim Kosse:

Yes, doesn't hurt. Can give you a more detailed analysis of what is wrong with your server.

Where can I share the credentials with you? Would a private email be ok? And if so, what email address can I sent them to?

comment:22 by Tim Kosse, 6 months ago

Status: newmoreinfo

tim.kosse@…

comment:23 by Gauthier BRIERE, 5 months ago

Status: moreinfonew

Hi,

Error:	FATAL ERROR: Remote side sent disconnect message
Error:	type 11 (by application):
Error:	"Unsupported protocol sequence"
Error:	Could not connect to server

This bug is alwais present for me from version 3.46.3 to the latest downloaded today 3.47.1...
Needed to downgrade to Filezilla 3.46.0 to have a working connection.
SFTP protocol version 3 on Debian... I don't have other info on my web host provider.
I can't update the server version since it's provider's responsability.
@++;
Gauthier.

Last edited 5 months ago by Gauthier BRIERE (previous) (diff)

comment:24 by Tim Kosse, 5 months ago

Resolution: fixed
Status: newclosed

Please try the most recent nightly build.

comment:25 by Gauthier BRIERE, 5 months ago

Hi @Tim,
It seems the problem is still present...
I downloaded the nightly build this morning and response from my server is :

Statut :	Connexion à competition.ffam.asso.fr:2221...
Réponse :	fzSftp started, protocol_version=9
Commande :	open "ffam-competition@competition.ffam.asso.fr" 2221
Commande :	Pass: ****************
Erreur :	FATAL ERROR: Remote side sent disconnect message
Erreur :	type 11 (by application):
Erreur :	"Unsupported protocol sequence"
Erreur :	Impossible d'établir une connexion au serveur

:-( => Return to 3.46.0...
Thanks for your work,
@++;
Gauthier.

comment:26 by Tim Kosse, 5 months ago

There are multiple issues jumbled together in this ticket. Some of these are server-side and require the server to be updated.

comment:27 by Gauthier BRIERE, 5 months ago

Hi Tim,
Thank you for your response and for your work on this magnificent software.
The fault may come from the server side, but unfortunately, I am only a client and I have no control over it.
In any case, Filezilla worked perfectly until version 3.46.0 and now that it has evolved, it no longer works while the server is still the same and it works normally with other clients.
So there is probably something to do in FileZilla ftp client to work around this potential server problem.
The error message is still the same than other in this thread:

FATAL ERROR: Remote side sent disconnect message
type 11 (by application):
"Unsupported protocol sequence"

Thanks for your work,
@++;
Gauthier.

comment:28 by BB, 5 months ago

Not sure why this is set as fixed when it's not. Tried the 3.47.2.1 and still get "Unsupported protocol sequence". 3.46.0 is the last version that works with sftp.

Its no good saying "update the server" when most of us don't have access to it.

comment:29 by Tim Kosse, 5 months ago

Just update your antique server software.

comment:30 by Gauthier BRIERE, 4 months ago

Hi @BB,

I agree with you, but they still did not understand that a large majority of users did not necessarily have control over the servers they use!

It works in version 3.46.0 and it no longer works in version 3.47! THIS is a FileZilla's fault!!
and the relpy:

update your antique server software

Is not a valid reply!!! And the resolution of this tread is NOT fixed.

Rather than allowing a backward compatibility mode with the old servers (there will always be!), These fundamentalists of the update do not want to hear anything ...
It is therefore no longer possible to take advantage of the latest client functionality on the new servers while continuing to work on the old ones.

Unfortunately I will resolve to change the FTP client, it's a shame, I liked Filezilla. :-(
But continuing like this, it's his own death that FileZilla is preparing in the short term...

I will use and advise my friends to use WinSCP (https://winscp.net/eng/index.php), another great open source software that does not seem to make the same mistakes.
Perhaps you should to do the same.

@ ++;
Gauthier.

comment:31 by BB, 4 months ago

Hi Gauthier.

I agree. I'll be dropping FileZilla and will try WinSCP and will recommend everyone here and where I work to do the same.

A shame as I've used FileZilla for years!

Regards.

comment:32 by Kevin Spetter, 3 months ago

I'm glad i found this ticket. I have an SFTP server that I am not the admin of that we send daily files too. All of a sudden we cannot send and once I roll back Filezilla to 3.46.0 everything works again. I can recommend the vendor to update their servers but it's their servers I can't force them so now I have to run an older version of Filezilla and hopefully not have issues with other connections by rolling back.

Note: See TracTickets for help on using tickets.