Opened 2 years ago

Last modified 2 years ago

#12037 new Bug report

During folder upload random files are skipped even though they appear in Successful transfer tab

Reported by: Kalpesh Popat Owned by:
Priority: normal Component: FileZilla Client
Keywords: transfer missing files Cc:
Component version: 3.45 Operating system type: OS X
Operating system version: macOS Catalina v 10.15

Description

Since last 3 versions of FileZilla i have noticed this bug which can be reproduced easily and with consistency

  1. In your local machine. Select multiple folders that have sub folders upto 3 levels and have files in them
  2. Upload them in remote server using FileZilla.
  3. Once the cycle is finished successfully check if all files have transferred.

Result:
In FileZilla all files will show under "Successfully Transferred" tab. But on server some files will still be missing randomly.

We found this out while releasing .net based application on google cloud server and since last 3 versions this bug appeared, .net application crashed randomly and upon checking we found some files were missing, so i checked in detail - i had the files in local folder, but they were missing in remote folder.

We even tried repeating the upload cycle multiple times and each time some missing files would get uploaded but still some files remained.

To overcome this issue now we are zipping the entire folder and uploading them - but then this approach requires access to terminal to complete the release process.

Change History (6)

comment:1 by Kalpesh Popat, 2 years ago

Component version: 3.45
Operating system type: OS X
Operating system version: macOS Catalina v 10.15

comment:2 by Kalpesh Popat, 2 years ago

We tried to upload completely new folder / replace existing folder with option to upload only if "date is new or file size different"

comment:3 by akaprog, 2 years ago

Same bug with Windows 10 and 3.46.0 FileZilla Pro

comment:4 by Tim Kosse, 2 years ago

Status: newmoreinfo

Which protocol are you using to upload?

in reply to:  4 comment:5 by akaprog, 2 years ago

Status: moreinfonew

Replying to Tim Kosse:

Which protocol are you using to upload?

For me it's sftp.

Friend in twitter told me that they have same issue with FileZilla and AWS.

Last edited 2 years ago by akaprog (previous) (diff)

in reply to:  4 comment:6 by Kalpesh Popat, 2 years ago

Replying to Tim Kosse:

Which protocol are you using to upload?

i am using ssh protocol

Note: See TracTickets for help on using tickets.