Opened 5 months ago

#11943 new Bug report

Failed authentication for the same user in the same tab with different password

Reported by: Viktor Owned by:
Priority: normal Component: FileZilla Client
Keywords: Cc:
Component version: 3.42.1 Operating system type: Windows
Operating system version: 10 Home

Description

This one is tricky, was giving me a headache. It's very specific, the following items must all be correct for the bug to show itself:

  • Must be the same tab
  • Must be the same SFTP user
  • Only thing that changes is password

So, we were testing a script that updates SFTP user's password. So I needed to test multiple new passwords for the same SFTP user.

I opened a tab and logged in successfully. Then I updated user's password, went into Site Manager and updated password there and clicked Connect. Authentication failed. This is all within the same tab.

I disconnected from the server in that tab. Then tried reconnecting again. It worked.

Next, I repeated these steps several times. If you're connected to the server with a user and password, changing password for that user and trying to reconnect without first disconnecting will result in authentication failure. If I try to do this in a new tab, it works fine.

My guess is, FileZilla tries to use old password even though I'm trying to connect with a new password. Sort of like a cache.

This happens if you use quick connect form or Site Manager.

I hope I described this problem clearly. I don't recall if this was ever an issue as I didn't have the need to change passwords and reconnect like this before.

Change History (0)

Note: See TracTickets for help on using tickets.