Opened 5 months ago

Closed 5 months ago

Last modified 5 months ago

#11941 closed Bug report (rejected)

Certificate for update.filezilla-project.org has been broken for me sinse May 26th

Reported by: rooeng Owned by:
Priority: low Component: Other
Keywords: certificate https ssl tls Cc:
Component version: Operating system type: OS X
Operating system version: 10.13.6

Description

Testing the URL: https://update.filezilla-project.org with online certificate checkers report errors. Missing intermediate certificate seems to be the problem. Chain ends at filezilla-project.org which is not a valid Root CA.

This problem has been reported with bug #11934 and rejected. I have tested this at multiple sites and https://update.filezilla-project.org always fails to load. Mostly tested with Chrome or Firefox on macOS.

Change History (6)

comment:1 Changed 5 months ago by Tim Kosse

Resolution: rejected
Status: newclosed

Don't use online certificate checkers. Use FileZilla's update mechanism to access the update server.

comment:2 Changed 5 months ago by rooeng

I used the certificate checker to determine why the site was failing to load.

comment:3 Changed 5 months ago by rooeng

The issue is being experienced by people using package management as reported here:

https://github.com/autopkg/keeleysam-recipes/issues/104

If you no longer support the update method outside the application, please let the community know.

comment:4 Changed 5 months ago by Tim Kosse

If you want to use a custom update mechanism you have to host the files yourself. Stop leeching of the FileZilla infrastructure.

comment:5 Changed 5 months ago by rooeng

I am trying to host the files myself. The system downloads the new update once and then hosts it for all internal machines. Right now that system is unable to download the update because of the certificate error. I guess it will need to be modified to download the full version when it changes instead.

comment:6 Changed 5 months ago by Tim Kosse

You can manually download FileZilla from https://filezilla-project.org/download.php

Note: See TracTickets for help on using tickets.