Opened 7 months ago

Closed 6 months ago

#11870 closed Bug report (fixed)

Version 3.41.0 unusably slow

Reported by: brusselsshrek Owned by:
Priority: critical Component: FileZilla Client
Keywords: performance Cc:
Component version: Operating system type: Windows
Operating system version: Windows 10 Pro

Description

I upgraded today to 3.41 (64-bit windows) and it is unusably slow. I estimate it is at least 100 times slower than earlier versions. For example, I regularly need to replace a complete subdirectory tree on the server and it usually takes less than second or so. With 3.41 it was taking longer than 10 minutes and barely made an impact, I gave up.

I also see that I cannot just jump from one directory to another, since I now get warnings that a directory synchronisation is taking place.

I wasn't sure that it was Filezilla the problem (maybe a network issue or a million other things), so I downgraded to 3.40 and all was good again. I then tried to reinstall 3.41 and all was slow again. I have now gone back to 3.40 until this gets fixed.

I am a long time user and big fan of Filezilla.

Change History (3)

comment:1 Changed 7 months ago by Tim Kosse

Status: newmoreinfo

Which FTP server software is running on the server machine?

comment:2 Changed 6 months ago by brusselsshrek

Status: moreinfonew

It looks like you found and fixed the problem:

3.41.1 (2019-03-06)
Bugfixes and minor changes:
Fix a regression introduced in 3.41.1 with slow FTP servers needlessly waiting for a bidirectional shutdown of the data connection during downloads

It works great again for me. Thanks!

comment:3 Changed 6 months ago by Tim Kosse

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.