Opened 6 months ago

Closed 6 months ago

#11867 closed Bug report (fixed)

Timeout on directory listing following update to 3.41.0

Reported by: Trent Owned by:
Priority: normal Component: FileZilla Client
Keywords: MLSD Cc:
Component version: 3.41.0 Operating system type: Windows
Operating system version: 10.0.17763.316

Description

I updated the FileZilla client to 3.41.0 this morning and am experiencing an issue during the directory retrieval process on 1 particular server. I regularly connect to about 12 different FTP servers on a daily basis and this is the only one giving me any issue.

Because of the sensitivity of information, I have obfuscated the host name, IP, username, and password in this public post. Happy to PM it to a tech for analysis if needed.

Status: Resolving address of ftp1.thehostname.com
Status: Connecting to #.#.#.#:21...
Status: Connection established, waiting for welcome message...
Response: 220 TheRDNS.hostname.us
Command: AUTH TLS
Response: 500 AUTH not understood
Command: AUTH SSL
Response: 500 AUTH not understood
Status: Insecure server, it does not support FTP over TLS.
Command: USER *
Response: 331 Password required for
*
Command: PASS
Response: 230 User
* logged in
Status: Server does not support non-ASCII characters.
Status: Logged in
Status: Retrieving directory listing of "/ZZZ Mr Master/CDN Files delivered"...
Command: CWD /ZZZ Mr Master/CDN Files delivered
Response: 250 CWD command successful
Command: TYPE I
Response: 200 Type set to I
Command: PASV
Response: 227 Entering Passive Mode. (#,#,#,#,68,229)
Command: MLSD
Response: 150 Opening ASCII mode data connection for MLSD
Error: Connection timed out after 20 seconds of inactivity
Error: Failed to retrieve directory listing

I have tried removing the remote directory that I am specifying in the site manager to land into, have tried forcing passive and active mode rather than auto-detect, have tried forcing UTF-8 instead of auto-detect, have tried checking bypass proxy, and have tried ALL available server types rather than auto-detect.

So far nothing has worked.

I can confirm that if I connect to this site from the command prompt ftp in windows 10 I am able to successfully connect and retrieve a directory listing.

I have inquired from the host as to what OS, FTP server, and version they are running to try to get more information. I'll update this ticket as I get more info.

I am certainly not alone as another user entered the IRC channel a little while ago with the identical issue, but he left before I was able to ask any questions.

Change History (7)

comment:1 Changed 6 months ago by Trent

I have confirmed reverting back to client version 3.40.0 restores functionality.

comment:2 Changed 6 months ago by Tim Kosse

Status: newmoreinfo

Please create a package dump of an attempt to list the directory using Wireshark and email it to tim.kosse@…, the contents of the dump will be treated confidentially.

comment:3 Changed 6 months ago by Trent

Status: moreinfonew

WireShark dump sent.

comment:4 Changed 6 months ago by Trent

The people running the server in question got back to me:

"It’s an older machine running Linux and ProFtpD"

Not much to go on, but just passing the word along.

comment:5 Changed 6 months ago by Tim Kosse

Status: newmoreinfo

Thank you, the information provided was very helpful.

Version 3.41.1 is in testing, please try this build: https://filezilla-project.org/codesquid/test/fz_3.41.1_testing.exe

comment:6 Changed 6 months ago by Trent

Status: moreinfonew

Glad to hear! Thanks, Tim!

I tried downloading the file you linked to in your last comment, but it's not allowing me to save it for some reason.

I can grab the nightly snapshot tonight/tomorrow morning and try it out unless you post a new RC for it.

comment:7 Changed 6 months ago by Trent

Resolution: fixed
Status: newclosed

Confirmed fixed in 3.41.1.

Thanks so much for making a great product!!!

Note: See TracTickets for help on using tickets.