Opened 10 months ago

Closed 9 months ago

#11813 closed Bug report (wontfix)

Wrong path at "File has changed" alert

Reported by: Ignacio Llorente Owned by:
Priority: normal Component: FileZilla Client
Keywords: path File has changed Cc:
Component version: 3.39.0 Operating system type: Windows
Operating system version: 10

Description

When editing a file by double-clic (using Notepad++), after saving changes and switch to FileZilla, it displays a wrong path and uses that wrong path to upload the file.

e.g.
Local path C:\wamp64\www\cloud\i\bibliotecas\181224\plantillas\tienda\.producto(product-detail).php

Correct remote path:
/var/www/i/bibliotecas/181224/plantillas/tienda/.producto(product-detail).php

Incorrect remote path
/var/www/i/bibliotecas/.producto(product-detail).php

Attachments (4)

1_originally_equal.png (34.9 KB) - added by Ignacio Llorente 10 months ago.
Original paths
2_Edited_and_saved.png (14.7 KB) - added by Ignacio Llorente 10 months ago.
2. after changes
3_Alert_with_wrong_path.png (77.2 KB) - added by Ignacio Llorente 10 months ago.
3. Alert with wrong path
4_uploaded_wrong_path.png (64.7 KB) - added by Ignacio Llorente 10 months ago.
4. Uploaded to wrong path

Download all attachments as: .zip

Change History (7)

Changed 10 months ago by Ignacio Llorente

Attachment: 1_originally_equal.png added

Original paths

Changed 10 months ago by Ignacio Llorente

Attachment: 2_Edited_and_saved.png added
  1. after changes

Changed 10 months ago by Ignacio Llorente

Attachment: 3_Alert_with_wrong_path.png added
  1. Alert with wrong path

Changed 10 months ago by Ignacio Llorente

Attachment: 4_uploaded_wrong_path.png added
  1. Uploaded to wrong path

comment:1 Changed 10 months ago by Tim Kosse

Status: newmoreinfo

Which remote directory was active when you first double-clicked the file?

comment:2 in reply to:  1 Changed 10 months ago by Ignacio Llorente

Status: moreinfonew

Thanks for the hint! These are the steps to reproduce the weird behaviour:

  1. Open FileZilla
  2. Note that Synchronized Browsing is off
  3. JFYI my base local folder is C:\wamp64\www\cloud\ and my base remote folder is /var/www/
  4. Go to a local folder (e.g. C:\wamp64\www\cloud\i\bibliotecas\181229b\one\)
  5. Go to a remote folder that is not the Synchronized one (e.g. /var/www/i/bibliotecas/181229b/two)
  6. Double click at one local file (e.g. C:\wamp64\www\cloud\i\bibliotecas\181229b\one\myfile.txt) it opens Notepad++ editing the file
  7. At FileZilla go to the remote folder that is the Synchronized one (e.g. /var/www/i/bibliotecas/181229b/one)
  8. Activate Synchronized Browsing
  9. At FileZilla go to another folder (e.g. /var/www/i/bibliotecas/181229b/three)
  10. At Notepad++ modify and save the file (in this example: C:\wamp64\www\cloud\i\bibliotecas\181229b\one\myfile.txt)
  11. Switch into FileZilla again.
  12. FileZilla detects the file’s change and suggest an upload… to the remote folder that was active when I start editing the file . In this example: /var/www/i/bibliotecas/181229b/two/myfile.txt

I would prefer this behavior:

a. When synchronized, compute paths using relative path:

When FileZilla detects a "File has changed": If Synchronized Browsing is ON, remote path (of the "File has changed dialog") would be the computed synchronized one . As in this example:

  • "File has changed dialog"'s local path is C:\wamp64\www\cloud\i\bibliotecas\181229b\one\myfile.txt
  • Present local path is C:\wamp64\www\cloud\i\bibliotecas\181229b\three
  • Present remote path is /var/www/i/bibliotecas/181229b/three
  • Synchronized Browsing is ON
  • So the relative path of the changed file is ../one/myfile.txt
  • So ... "File has changed dialog"'s remote path would be /var/www/i/bibliotecas/181229b/three/../one/myfile.txt , so /var/www/i/bibliotecas/181229b/one/myfile.txt would be the remote path I expected.

b. Let FileZilla keep "Synchronized browsing" status on Startup:

Edit > Settings > Interface > on Startup of FileZilla > Restore tabs, restore "Synchronized browsing status" and reconnect

Replying to Tim Kosse:

Which remote directory was active when you first double-clicked the file?

Last edited 10 months ago by Ignacio Llorente (previous) (diff)

comment:3 Changed 9 months ago by Tim Kosse

Resolution: wontfix
Status: newclosed

Functionality is working as intended.

Note: See TracTickets for help on using tickets.