Opened 13 months ago

Closed 13 months ago

Last modified 13 months ago

#11798 closed Bug report (worksforme)

Upload Issues

Reported by: tngweb Owned by:
Priority: high Component: FileZilla Client
Keywords: Cc:
Component version: Pro 3.38.1 Operating system type: Windows
Operating system version: 10 Pro v1803 Build 17134.376 64-bit

Description

Having issues with uploading files to remote servers.

When uploading, the directories are created, however, the individual files are failing to upload, even though FileZilla reports ALL files successfully uploaded.

I have confirmed this problem using different computers, as well as uploading to different servers using varying configurations. The program specs are below. Note, this issue is present with Windows servers as well as Linux servers.

I CAN go into the individual directories and upload the files without issue.

FileZilla Pro


Version: 3.38.1

Build information:

Compiled for: x86_64-w64-mingw32
Compiled on: x86_64-pc-linux-gnu
Build date: 2018-10-29
Compiled with: x86_64-w64-mingw32-gcc (GCC) 6.3.0 20170516
Compiler flags: -g -O2 -Wall

Linked against:

wxWidgets: 3.0.5
SQLite: 3.22.0
GnuTLS: 3.5.19

Operating system:

Name: Windows 10 (build 17134), 64-bit edition
Version: 10.0
Platform: 64-bit system
CPU features: sse sse2 sse3 ssse3 sse4.1 sse4.2 avx aes pclmulqdq lm
Settings dir: C:\Users\TREKK\AppData\Roaming\FileZilla\

Attachments (3)

filezilla.log (714.0 KB) - added by tngweb 13 months ago.
Most recent log
modules.zip (19.0 MB) - added by tngweb 13 months ago.
filezillaTEST.log (1.2 MB) - added by tngweb 13 months ago.
Test site log

Change History (17)

Changed 13 months ago by tngweb

Attachment: filezilla.log added

Most recent log

comment:1 Changed 13 months ago by Tim Kosse

Resolution: rejected
Status: newclosed

The logs shows 88 uploads, all of which have been successful as acknowledged by the server.

If these files cannot be found on the server following the transfer it means someone must have deleted them between uploading the files and looking for them.

comment:2 Changed 13 months ago by tngweb

Resolution: rejected
Status: closedreopened

You are incorrect. This issue has been ongoing for quite some time now. Those 88 files are directories. There is over 500 images and pop files that are not being uploaded. This problem has been around for nearly 5 major updates. I am currently working with a FRESHLY installed computer AND FileZilla

comment:3 Changed 13 months ago by Tim Kosse

The log clearly shows 88 file transfers, all of which are successful.

88 lines with "Status: Starting upload" and 88 lines of "Status: File transfer successful"

In addition there are many empty local directories which as part of the upload are also created remotely.

comment:4 Changed 13 months ago by tngweb

I must ask, did you even read the complete report?

Uploads that I am trying to upload are part of WHMCS.

Using other FTP clients, I have no issues. IE, CuteFTP, Core FTP, and PrivateShell to name a few.

comment:5 Changed 13 months ago by Tim Kosse

Status: reopenedmoreinfo_reopened

Please give an example of a file from the log that has failed to upload.

Changed 13 months ago by tngweb

Attachment: modules.zip added

comment:6 Changed 13 months ago by tngweb

Status: moreinfo_reopenedreopened

Requested file attached. Contains 6,213 Files, 1,885 Folders.

comment:7 Changed 13 months ago by Tim Kosse

Of these 6213 files you have selected all 88 image image files through the use of filters and uploaded these images.

These uploads have all been successful according to both FileZilla and the server.

comment:8 Changed 13 months ago by tngweb

And what about the other 6,215 files? Did they upload properly, or did you have to go into each individual directory and upload the respective files?

Changed 13 months ago by tngweb

Attachment: filezillaTEST.log added

Test site log

comment:9 Changed 13 months ago by tngweb

Added a log file for a test site. Again, only directories are being created, nothing is being uploaded into those directories.

comment:10 Changed 13 months ago by Tim Kosse

Resolution: worksforme
Status: reopenedclosed

This is working as intended. If you use a directory listing filter to only upload images, then only images are being uploaded.

comment:11 Changed 13 months ago by tngweb

There are NO filters enabled. I am using the DEFAULT settings set by FileZilla upon installation. As I said in my first post, this is a CLEAN INSTALL of the program.

comment:12 Changed 13 months ago by Tim Kosse

Please check the directory listing filter icon in the toolbar, it is the 4th icon from the right. Filters are enabled if the icon shows as depressed.

comment:13 Changed 13 months ago by tngweb

As stated, NO filters are enabled.

Understand, I have been using FileZilla since the first release and know the program very well. I have NEVER had this issue BEFORE v3.2. As soon as v3.3 and on came out, I have had this issue.

Last edited 13 months ago by tngweb (previous) (diff)

comment:14 Changed 13 months ago by Tim Kosse

Facts: Both logs show a successful upload of 88 images and creation of a bunch of directories containing no images.
Claim 1: Source directory containing 6215 files
Claim 2: No filters enabled

Given the facts it is not possible for both claims to be true, they are mutually exclusive.

This mean that you either have filters enabled or that the source directory not contain 6215 files, but instead only these 88 image files and a bunch of empty directories.

Note: See TracTickets for help on using tickets.