Opened 13 years ago

Closed 2 years ago

#1168 closed Feature request (fixed)

openssh banners not displayed

Reported by: hirschma Owned by: Alexander Schuch
Priority: normal Component: FileZilla Client
Keywords: banner sftp Cc: hirschma, Alexander Schuch, Tim Kosse, amatthews@…
Component version: Operating system type: Windows
Operating system version: Windows 8,8.1,7 (x64), Linux Mint x64

Description (last modified by Tim Kosse)

Login Banners displayed by the openssh sftp-server are
not displayed in the Filezilla client.

From my sshd_config:

Banner /etc/ssh/sshd-banner

The referenced banner displays when ssh'ing into the
server, and when using the sftp command from console as
well. Filezilla, however, seems to strip such banners out.

Change History (11)

comment:1 Changed 13 years ago by Tim Kosse

Does the banner get displayed if using psftp from PuTTY?

comment:2 Changed 13 years ago by hirschma

Yes, psftp from PuTTY works 100%.

comment:3 Changed 13 years ago by Alexander Schuch

Can you please try again with most recent version of FileZilla 2 or preferably even FileZilla 3 (beta)?

Furthermore, "man 5 sshd_config" says regarding "Banner" option: "This option is only available for protocol version 2." Maybe that could help?

comment:4 Changed 12 years ago by sf-robot

This Tracker item was closed automatically by the system. It was
previously set to a Pending status, and the original submitter
did not respond within 14 days (the time period specified by
the administrator of this Tracker).

comment:5 Changed 9 years ago by Allan Matthews

Cc: amatthews@… added
Operating system type: Windows
Status: closedreopened

I see this issue. I can also reproduce with putty and sftp on a linux box. I am connecting to an openssh 1.0.0d server that is protocol 2 only.

FileZilla Client


Version: 3.4.0

Build information:

Compiled for: i586-pc-mingw32msvc
Compiled on: x86_64-unknown-linux-gnu
Build date: 2011-03-27
Compiled with: i586-mingw32msvc-gcc (GCC) 4.2.1-sjlj (mingw32-2)
Compiler flags: -g -O2 -Wall -g -fexceptions

Linked against:

wxWidgets: 2.8.12
GnuTLS: 2.10.4

Operating system:

Name: Windows NT 6.1 (build 7600)
Version: 6.1
Platform: 64 bit system

comment:6 Changed 9 years ago by Allan Matthews

to clarify I can produce the correct result (banner seen) on psftp (putty) on the same windows host. I can also see the correct result using an sftp client from a linux box.

comment:7 Changed 6 years ago by Peter Duffy

We're also experiencing this problem (filezilla 3.7.3) - it's a major issue for us, as we need to display a banner warning that the system is private and monitored. Basically, it means that at present we can't use filezilla.

Is anyone working on this issue?

comment:8 Changed 5 years ago by mike latessa

Operating system version: Windows 8,8.1,7 (x64), Linux Mint x64

Any plans to fix this bug? Banner works with alternative clients like WinSCP

comment:9 Changed 5 years ago by Bruno Ramos

Some Notes :

Putty is showing the banner correctly.
But the banner is showing only after the login is entered (see below)

There's a putty configuration option to control if putty displays the banner or not "ssh_show_banner"


login as: brunoramos
Debian GNU/Linux 7

#########################################################

This is a private and monitored system.
Disconnect IMMEDIATELY if you are not an authorized user!

#########################################################

brunoramos@192.168.122.17's password:
Access denied
brunoramos@192.168.122.17's password:
Linux debian-kvm 3.2.0-4-amd64 #1 SMP Debian 3.2.51-1 x86_64

The programs included with the Debian GNU/Linux system are free software;
the exact distribution terms for each program are described in the
individual files in /usr/share/doc/*/copyright.

Debian GNU/Linux comes with ABSOLUTELY NO WARRANTY, to the extent
permitted by applicable law.
You have mail.
Last login: Sat Sep 6 16:16:57 2014 from 192.168.122.1


comment:10 Changed 2 years ago by Kurt McKee

Keywords: banner sftp added
Type: Bug reportFeature request

Triage suggestion

I have set up a Linux VM and can confirm that psftp and putty will display the login banner over SSH and SFTP. It appears that FileZilla Client doesn't display the login banner. Based on what I'm seeing in version 3.26.1 it appears that this is not a bug -- login banners appear to not be implemented. I'm changing the ticket type to "Feature request" as a result.

However, I suggest closing this ticket as "rejected" for lack of movement.

comment:11 Changed 2 years ago by Tim Kosse

Description: modified (diff)
Resolution: fixed
Status: reopenedclosed

Login banners have no semantic meaning, the protocol does not require that they be displayed.

Note: See TracTickets for help on using tickets.