Opened 17 years ago

Last modified 17 years ago

#115 closed Bug report

MKDIR not compatible with LINUX FTP serv

Reported by: anonymous Owned by:
Priority: normal Component: Other
Keywords: Cc: links2learning, scottdf, Tim Kosse
Component version: Operating system type:
Operating system version:

Description

MKDIR add / at the end of path. This cause error 553
Could not determine cwdir: No such file or directory.

a / at the end of path is not a correct path for MKDIR
command !

No upload is possible on any LINUX SUZE version with
FILEZILLA !

Please, DO NOT HAD / at the end of PATH ! ! !

Change History (9)

comment:1 Changed 17 years ago by links2learning

Are you sure about this?

I have tried to reproduce this error without any luck.

Can we work together on identifing the bug?

Cheers, Clive

comment:2 Changed 17 years ago by scottdf

Clive,

You mention you cannot reproduce this. I can, although I get
a different msg.

--- snipped from FileZilla log ---
Command: MKD /sdf/
Response: 550 /sdf/: No such file or directory.

--- end snip ---

I get this even if I remove the slash after the directory name.

The FTP server is at Road Runner.
FTP server (BSDI Version 7.00LS) ready.

Other FTP clients are able to do this successfully.

Scott

comment:3 Changed 17 years ago by links2learning

Hi,
I've tried NcFTPd is a high-performance File Transfer Protocol (FTP)
server for UNIX and every thing works fine!

Must be a Linux problem?

Clive

comment:4 Changed 17 years ago by scottdf

I tried this on a Linux-based site last night and it worked
fine. I still cannot get it to work on the Road Runner site
listed below.

Scott

comment:5 Changed 17 years ago by links2learning

Direct from the horses mouth!
Reply Email
Subject: Re: NcFTPd

From: Mike Gleason <mgleason@…>
Date: Wed, 22 May 2002 10:09:21 -0500

To: ##### Links2Learning Clive sabey

On Wednesday, May 22, 2002, at 04:58 AM, stfcs wrote:

Command: MKD /sdf/

Does it require the last / or not?

It should be MKD /sdf

Mike Gleason
NcFTP Software
http://www.NcFTP.com

comment:6 Changed 17 years ago by scottdf

Thus the method in FileZilla should be changed.

Thanks, Clive for checking this out. Hopefully a fix will be
soon forthcoming.

Scott

comment:7 Changed 17 years ago by anonymous

Logged In: NO

This bug appear also on LINUX SUZE 6.2

It is only due to the behavior of FTP server wich does not
accept such pathnames ending with / wich are normaly not
correct

comment:8 Changed 17 years ago by Tim Kosse

This bug will be fixed in FileZilla 1.9.8,
a beta version can be downloaded here:
http://filezilla.sourceforge.net/FileZilla_1_9_8_beta_3.zip

comment:9 Changed 17 years ago by Tim Kosse

Here's another beta version:
http://filezilla.sourceforge.net/FileZilla_1_9_8_beta_4.zip
All remaining MKD issues have be fixed

Note: See TracTickets for help on using tickets.