Opened 2 years ago

Closed 2 years ago

#11485 closed Other (worksforme)

Appears to be variance in Filezilla allocating the correct download bandwidth especially when downloading multiple files

Reported by: mccannger Owned by:
Priority: low Component: FileZilla Client
Keywords: bandwidth download multiple-download Cc:
Component version: 3.29.0 Operating system type: Windows
Operating system version: Windows 10 build 16299

Description

I love Filezilla and till this latest version it has been excellent at downloading multiple files (for me it downloads 2 simultaneously) and while doing so maxing the bandwidth and splitting it pretty much evenly between the files.

This latest version seems to occasionally (say 5 out of every 10 loads of the program) either (1) pick up only a fraction of the available bandwidth for single file downloads, and/or (2) allocate the bandwidth unevenly between multiple files, e.g. 1 will get 300-600 KiB/s with the second getting 4.1MiB/s.

The workaround for the above is to right click on one of the downloading files, and uncheck 'Process Queue'. If I then wait for like 10 secs, the bandwidth seems to be allocated correctly (2.1MiB/s to each file).

NOTE: this has happened over several days, and after restarts of both the FTP server supplying the files, the modem, and computer running Filezilla. I did not notice it in previous versions. It therefore seems like it could be some kind of low priority issue.

Thanks for a great product and for any help with this issue.

Change History (4)

comment:1 Changed 2 years ago by Tim Kosse

Status: newmoreinfo

Do you by chance have speed limits enabled in FileZilla?

comment:2 Changed 2 years ago by mccannger

Status: moreinfonew

Hi codesquid, no speed limits enabled. Thanks

comment:3 Changed 2 years ago by mccannger

Hi again. I tried to replicate this but was unable to. That being said, it has happened enough times in recent past to make me think there is *something* going on, but given the challenge with replication, perhaps it is environmental though I was convinced I had restarted my internet connection. It is possible it was flaky and thus FZ was 'seeing'max ISP connection speed at a moment in time, whereas a few seconds later the ISP connection speed increased hence why the second download got a faster speed. That may also explain why when I stop the downloads and restart them, they both get the same speed.

Please close the issue and I'll watch out for it happening again and try to rule out environmental issues before I come back about it.

Appreciate your help.

comment:4 Changed 2 years ago by Tim Kosse

Resolution: worksforme
Status: newclosed

Cannot reproduce.

Note: See TracTickets for help on using tickets.