Opened 23 months ago

Last modified 18 months ago

#11463 new Bug report

FileZilla Client 3.x Silent Uninstall fails

Reported by: Derrick Anderson Owned by:
Priority: normal Component: FileZilla Client
Keywords: Quiet Silent Unattend Uninstall Clean Up Cc:
Component version: Filezilla 3.x (32 & 64 bit) Operating system type: Windows
Operating system version: Windows 7.1604.11.13 and Windows 10.1604.11.16

Description

Greetings,

I work in an enterprise environment that requires Silent \ Unattended installs and uninstalls to be distributed via command line and SCCM.


Issue 1:


We have confirmed that the filezilla 3.x (32 and 64 bit) Silent Uninstall Command line fails to cleanly remove the application. BUT, it cleanly removes itself if run manually and users attend to the prompts.

They all seem to use the same uninstall Command Line & Registry Key Name :

  • Command Line : "C:\Program Files (x86)\FileZilla FTP Client\uninstall.exe" /S
  • Registry Key Name: HKLM\Software\..\Microsoft\Windows\CurrentVersion\Uninstall\FileZilla Client

Steps to confirm ...

  1. "MANUAL\ATTENDED" Uninstall is successful
    1. Install any FileZilla 3.x and restart the machine
    2. Uninstall filezilla via Add Remove programs (Controls Panel\Programs & Features)
  1. "SILENT \ UNATTENDED" Uninstall FAILs
    1. Install any FileZilla 3.x and restart the machine
    2. Uninstall filezilla via the command line : "C:\Program Files (x86)\FileZilla FTP Client\uninstall.exe" /S

Issue 2:


Also, one of my clients had a previous 64bit version installed but then needed the 32 bit instead. It would appear that the 32 installer is installing as 64 bit - this DOES NOT occur if x64 was NOT previous installed on a system.

Testing Steps to confirm ...

  1. Uninstalled FileZilla_3.27.0.1_win64-setup_bundled.exe via command line : "C:\Program Files (x86)\FileZilla FTP Client\uninstall.exe" /S
  2. Restarted the machine
  3. Installed FileZilla_3.29.0_win32-setup.exe
  4. This 32 bit installs itself in the "C:\program files (x86)" folder if there was not 64 bit installed before it; but this 32 bit installer is putting itself into the previous 64 bit folder "C:\Program Files" if the 64 bit was installed before.

I hope this was submitted properly; my many thanks in advance!

Best Regards Derrick.

Change History (8)

comment:1 Changed 23 months ago by Tim Kosse

Status: newmoreinfo

Let's start with issue 2.

The installation behavior is intentional, regardless which version you are installing, it installs over an existing installation by default to prevent multiple installations in different directories, the latter which would just lead to big confusion.

However the real issue with 2 is why would somebody with the 64bit version suddenly need the 32bit version? The 32bit version has exactly the same set of features, it's however much slower.

Onto issue 1, did you run the silent uninstaller as elevated process?

comment:2 Changed 23 months ago by Tim Kosse

Oh, also please update to the most recent version of FileZilla, we cannot support outdated versions. Please update first, then read my previous reply.

comment:3 Changed 23 months ago by Derrick Anderson

Status: moreinfonew

Hi thank you for the prompt reply.

Our standard is to uninstall any app and reinstall with its newer one - we rather not run updates over pre-existing installations as it can cause issues and clutter on machines.

Issue 2 response : i didn't quite understand the business case for it either but this shouldn't matter, since our mandate is to remove the pre-existing product before installing the new version of the product. I only brought it up in case it was significant to the failing silent uninstall behavior.

Issue 1 response : yes i did run the silent install with my admin account, directly via the command line : "C:\Program Files (x86)\FileZilla FTP Client\uninstall.exe" /S via CMD.EXE

Thanks again for the prompt reply, and assistance, it is very much appreciated!

comment:4 in reply to:  2 Changed 23 months ago by Derrick Anderson

PS - FileZilla_3.29.0_win32-setup.exe is the most current version we are using from the download page - it is the one used with this case - https://filezilla-project.org/download.php?show_all=1

Last edited 23 months ago by Derrick Anderson (previous) (diff)

comment:5 Changed 18 months ago by Toby Williams

Hi,

I've been able to replicate this issue using v3.32.0.

My uninstall command is '%INSTALL_DIR%\uninstall.exe /S ', this runs as part of a WPKG package as the system user.

Whilst monitoring the uninstaller I see that it hangs on the resources\default directory (there is always one randomly selected directory in here which can't be deleted, I've seen 16x16 and 480x480 stuck so far). When I try and access the folder whilst the uninstaller is running I see 'access denied or the folder does not exist'. When cancelling the uninstaller the directory which I just tried accessing disappears.

If I run the same uninstall command in cmd or powershell as admin then it works fine. I also noticed that if I run the uninstall command as SYSTEM from either a .bat or .ps1 script then it all runs just fine.

Please let me know if you need any more information.

Toby

comment:6 Changed 18 months ago by Tim Kosse

Status: newmoreinfo

Are you using any virus scanners? They can interfere with filesystem operations.

comment:7 Changed 18 months ago by Derrick Anderson

Status: moreinfonew

No virus scanner on both Win7 x64 and Win10 x64, and both are vanilla builds.

comment:8 Changed 18 months ago by Derrick Anderson

Glad to see this matter was picked up again; we've have been patiently waiting 5+ mths for a viable work-around\solution.

Looking forward to seeing a solution\work-around this time around if at all possible ... Many thanks in advance for taking this on again CodesGUID! Out of curiosity, have you been able to successfully uninstall the media silently for both of the following scenarios using the command line (if so what command lines did you use exactly?):

  1. Uninstall the application after it has had patches installed over a pre-existing base installation?
  2. Uninstall the application after it was installed - without being patched.

RECAP :
I have Confirmed that the recommended unattended\silent command line does NOT work still, even for the current release 3.32.x and all others since i first reported it for v27.x, when executed via Powershell and(or) CMD.EXE : "C:\Program Files (x86)\FileZilla FTP Client\uninstall.exe" /S via CMD.EXE

This raises major concerns for enterprise users. How can they upgrade to the next version when the unattended uninstall command line is consistently failing on multiple machines, when trying to uninstall itself. This can be quite a timely and costly thing to address when needing to send Techs to each users machine to address them - especially when upgrading in an enterprise environment with multiple users.

Last edited 18 months ago by Derrick Anderson (previous) (diff)
Note: See TracTickets for help on using tickets.