Opened 22 months ago

Last modified 6 weeks ago

#11378 reopened Bug report

MacOS Copy Paste feature

Reported by: Adadgio Owned by:
Priority: normal Component: FileZilla Client
Keywords: Cc:
Component version: ALL Operating system type: OS X
Operating system version: ALL

Description

On Filezilla Mac OSX version, copy pasting anything in text boxes (for instance when editing websites or configuration) does not paste text but instead "creates a new Bookmark" (even when input is focused).

All previously changed configuration in inputs is lost if you were adding a website.

It's especially annoying not to be able to ⌘ + V... ;-)

I have noticed the issue on all MAC computers i use and since a lot of versions.

Attachments (1)

Mac Copy Past Hostname Error Message.png (252.7 KB) - added by bnmdev 16 months ago.

Download all attachments as: .zip

Change History (12)

comment:1 Changed 22 months ago by Adadgio

Priority: highnormal

comment:2 Changed 22 months ago by Tim Kosse

Resolution: worksforme
Status: newclosed

Cannot reproduce. Make sure to press the v key to paste, not the b key. They are located right next to each other after all.

comment:3 Changed 22 months ago by Adadgio

Resolution: worksforme
Status: closedreopened

Positively sure. ⌘ + V is pressed.

comment:4 Changed 21 months ago by Tim Kosse

Resolution: worksforme
Status: reopenedclosed

Still cannot reproduce.

comment:5 Changed 17 months ago by Talbi Taoufiq

Hello,

I have this problem since last year, still waiting for a solution with the updates but it still occurs even with the latest versions.
If you can check please.

Thank you

Changed 16 months ago by bnmdev

comment:6 Changed 16 months ago by bnmdev

Hello,

Same problem here. When I paste something in "Host" field, i get an error because the ⌘ + V is triggering the creating of a new bookmark. Weird ...

FileZilla Client
----------------

Version:          3.30.0

Build information:
  Compiled for:   x86_64-apple-darwin16.7.0
  Compiled on:    x86_64-apple-darwin16.7.0
  Build date:     2018-01-08
  Compiled with:  Apple LLVM version 9.0.0 (clang-900.0.39.2)
  Compiler flags:  -Werror=partial-availability -Wall -g -std=gnu++14

Linked against:
  wxWidgets:      3.0.4
  SQLite:         3.19.3
  GnuTLS:         3.5.13

Operating system:
  Name:           Mac OS X (Darwin 17.4.0 x86_64)
  Version:        10.13
  CPU features:   sse sse2 sse3 ssse3 sse4.1 sse4.2 avx avx2 aes pclmulqdq rdrnd bmi2 bmi2 adx
  Settings dir:   /Users/ben/.config/filezilla/

comment:7 Changed 15 months ago by bnmdev

Resolution: worksforme
Status: closedreopened

comment:8 Changed 14 months ago by b33tl3

hello there, same for me.

trying to paste text into Site manager host field or comment field, with CMD+V shortcut displays a error message "Invalid Data, you must type a hostname"
(in french :
Gestionnaire de sites - données invalides
Vous devez saisir un nom d'hôte)


FileZilla Client


Version: 3.32.0

Build information:

Compiled for: x86_64-apple-darwin17.4.0
Compiled on: x86_64-apple-darwin17.4.0
Build date: 2018-04-03
Compiled with: Apple LLVM version 9.1.0 (clang-902.0.39.1)
Compiler flags: -Werror=partial-availability -Wall -g -std=gnu++14

Linked against:

wxWidgets: 3.0.5
SQLite: 3.19.3
GnuTLS: 3.5.18

Operating system:

Name: Mac OS X (Darwin 15.6.0 x86_64)
Version: 10.11
CPU features: sse sse2 sse3 ssse3 sse4.1 sse4.2 avx avx2 aes pclmulqdq rdrnd bmi2 bmi2
Settings dir: /Users/cedric/.config/filezilla/


Thanks for trying to fix this issue.
have a nice day, keep up the good work :)

comment:9 Changed 8 months ago by cutesquirrel

Hi,
I had exactly the same issue since many months.
I tried right now to switch my language from French to English and the issue doesn't exist on this language.
So the CMD+V shortcut creates a bookmark only in the site manager, only for French language (or maybe other languages, but English)
Hope this helps
Cheers

comment:10 in reply to:  9 Changed 8 months ago by Talbi Taoufiq

Replying to cutesquirrel:

Hi,
I had exactly the same issue since many months.
I tried right now to switch my language from French to English and the issue doesn't exist on this language.
So the CMD+V shortcut creates a bookmark only in the site manager, only for French language (or maybe other languages, but English)
Hope this helps
Cheers

Niiiice, that was it :) cheeeeers

comment:11 Changed 6 weeks ago by Carmine Pizza

Same problem for Italian language

Note: See TracTickets for help on using tickets.