Opened 13 years ago

Last modified 13 years ago

#1136 closed Bug report

Invalid password sent from client to server with euro char

Reported by: jochenwezel Owned by:
Priority: high Component: FileZilla Client
Keywords: Cc: jochenwezel, Tim Kosse
Component version: Operating system type:
Operating system version:

Description

Environmental information:

  • One of our passwords contains a Euro character (€).
  • The tested connection type is FTP over SSH2
  • We use the .xml config file

In version 2.2.22, it worked fine. Since we updated to
version 2.2.25, the password isn't accepted anymore.

When does the error happens?
The error always happens when we try to open the one
connection.

When does the error NOT happens?
I can setup my connection properties, reenter the
password there and click on "connect", then the server
accepts my password. (But if I press "Save" and then
connect again, it doesn't work, too.)

Change History (6)

comment:1 Changed 13 years ago by Tim Kosse

Can you please try if you can reproduce this problem using
the upcoming FileZilla 3? You can download a test version
from http://filezilla-project.org/nightly.php
(i586-mingw32msvc target)

comment:2 Changed 13 years ago by jochenwezel

I've tested the build from 2006-07-19 and entered manually
the new connection item to my server. And there has been no
error (also after a restart of the application all things
worked fine).

(But this dev version doesn't use XML files currently, I
don't know if there can be an issue.)

comment:3 Changed 13 years ago by jochenwezel

Sorry, I might have changed accidentially the status from
pending to open? If wrong, please correct... Thanks!

comment:4 Changed 13 years ago by Tim Kosse

FZ3 uses XML files, but they are now stored in
$APPDATA%\FileZilla

comment:5 Changed 13 years ago by jochenwezel

Regarding XML: I've contacted you directly to avoid
unnessary noise here

Regarding this euro char error here a testing overview:

  • FZ 2.2.22: Fine
  • FZ 2.2.25: Bugggy
  • FZ 3 alpha / 2006-07-19: Fine

comment:6 Changed 13 years ago by Tim Kosse

Proper solution is to either use an UTF-8 enabled server or
to avoid using non-english characters. As workaround you
could use FileZilla 3.

Note: See TracTickets for help on using tickets.