Opened 2 years ago

Last modified 2 years ago

#11347 new Bug report

deleting symlink deletes files in linked folder

Reported by: seebold Owned by:
Priority: normal Component: FileZilla Client
Keywords: symlink, delete, FTP, linux, windows Cc:
Component version: 3.27.0.1 Operating system type: Windows
Operating system version: 10

Description

Filezille Version 3.27.0.1
Used Protokoll: FTP
Server OS: Debian Linux

Dear developer-team,

A unexpected behaviour led to a middle disaster, yesterday. We link to source of a TYPO3-installation via symlink so different installations use one source folder. I cleaned up the server and deleted a test installation with filezilla. Unfortunately fileziller deleted all files in the linked source folder, so all other TYPO3 instalations lost their source.

I just tried:
mkdir deletetest
fisch:~/public_html$ touch deletetest/eins
fisch:~/public_html$ touch deletetest/zwei
fisch:~/public_html$ touch deletetest/drei
fisch:~/public_html$ ln -s deletetest/ testdelete

Now I deleted testdelete via Filezilla and got:
fisch:~/public_html$ ls -l deletetest/
total 0
and still exits:
0 lrwxrwxrwx 1 fisch fisch 11 Jul 28 19:39 testdelete -> deletetest/

Filezilla deleted the content of the linked folder, not the symlink itself. This is not, what I was expecting and can lead to big problems. This should be solved eg. behave as expected and deleting the symlink by default, giving an option in the setting dialog with a choice, how to behave or ask on deleting symlinks.

Thnaks for your work
Martin

Change History (1)

comment:1 Changed 2 years ago by Tim Kosse

Type: PatchBug report
Note: See TracTickets for help on using tickets.