Opened 3 years ago

Closed 3 years ago

#11317 closed Bug report (fixed)

Folder handling during S3 download is not correct

Reported by: larry.ellis Owned by:
Priority: normal Component: FileZilla Client
Keywords: S3 folder directory Cc:
Component version: 3.26.2 Operating system type: Windows
Operating system version: Windows 10

Description

When using Filezilla Pro Client and downloading from Amazon S3 storage, handling of folders seems wrong.

If you select a folder on the remote size and then try to download it, behavior is inconsistent:

  1. If the folder already exists on the local side, the files are transferred into that folder as expected.
  1. If the folder does not exist on the local side, the download fails for each file because the folder path does not exist.

In case 2, I believe expected behavior is for FileZilla to create the missing folder and proceed. This would be consistent with its behavior for FTP sources.

Change History (1)

comment:1 by Tim Kosse, 3 years ago

Resolution: fixed
Status: newclosed

Thanks for reporting this issue. It will be fixed in the next version of FileZilla Pro.

Note: See TracTickets for help on using tickets.