Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#11047 closed Bug report (fixed)

Incorrect directory nesting when moving files on remote server

Reported by: Steve Owned by:
Priority: normal Component: FileZilla Client
Keywords: Cc:
Component version: 3.22.1 Operating system type: Windows
Operating system version: 10

Description

This is issue only happens when moving directories on the remove server.

Directory/File Structure:
root
root/app
root/magento
root/magento/app
root/magento/app/file.txt

When I click-and-drag the root/magento/app directory up 1 level into root, I would expect the root/app directory to contain file.txt. Instead, FZ is nesting the app directories so I have root/app/app/file.txt.

This is easily reproducible and I do not believe it is intended behavior.

Makes magento/extension upgrades very difficult and just destroyed my dev site.

Change History (1)

comment:1 by Tim Kosse, 4 years ago

Resolution: fixed
Status: newclosed

Thanks, this will be fixed in the next version of FileZilla.

Depending on the used server, such renames will most likely fail instead as the target name already exists.

Last edited 4 years ago by Tim Kosse (previous) (diff)
Note: See TracTickets for help on using tickets.