Opened 3 years ago

Closed 3 years ago

#10999 closed Bug report (worksforme)

Extensive memory allocation

Reported by: Sebastian Martin Dicke Owned by:
Priority: normal Component: FileZilla Client
Keywords: memory Cc:
Component version: 3.21 Operating system type: Linux
Operating system version: 4.7.4

Description

When I tried to upload > 200k files with a size of circa 750 GB to a SFTP server, the client application allocated almost 10 GB memory which leaded on a system with 15.5 GB RAM and a 16 GB swap partition to an effective unusable system state. I was unable to switch to another TTY and I was not able to kill to application or execute another action as moving the mouse cursor. I used the application with KDE Plasma 5.7.4.

I suggest to confine the usage of resources to avoid such situations.

Change History (1)

comment:1 Changed 3 years ago by Tim Kosse

Resolution: worksforme
Status: newclosed

Cannot reproduce.

Sounds like you have a memory leak in one of your system libraries.

Please use a good memory leak checker to identify the faulty library and file a bug report against that library.

Note: See TracTickets for help on using tickets.