Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#10893 closed Bug report (duplicate)

FileZilla can not handle leading blank spaces in directory names

Reported by: Dirk Owned by:
Priority: normal Component: FileZilla Client
Keywords: folder names with leading blanks Cc:
Component version: 3.19.0 Operating system type: Windows
Operating system version: 10 Pro

Description

At least on Unix file systems (I didn't try Windows) FileZilla has problems, when the first character of a directory name is a blank.
You can rename "/xy/testdir" to "/xy/ testdir" with FileZila
and "/xy/ testdir" is shown correctly.
But after refreshing, it is shown as:"/xy/testdir" and can not be accessed with FileZilla any more or in any way.
You get:
Error: Directory /testdir: no such file or directory
Error: Failed to retrieve directory listing

This is correct, but does not help :)

It is not an issue of the Unix filesystem, because with other FTP-clients (e.g. WS_FTP Professional) everything works fine.

You may ask, why the hell is someone using one or more leading blanks in folder names. OK, I have to do it, but can't do it with FileZilla, so I had to change to another FTP client.
Please fix this, Thanks!

Content of FileZilla Info:

FileZilla Client


Version: 3.19.0

Build information:

Compiled for: x86_64-w64-mingw32
Compiled on: x86_64-unknown-linux-gnu
Build date: 2016-06-27
Compiled with: x86_64-w64-mingw32-gcc (GCC) 4.9.1
Compiler flags: -g -O2 -Wall -g -std=gnu++14

Linked against:

wxWidgets: 3.0.3
GnuTLS: 3.4.10
SQLite: 3.11.1

Operating system:

Name: Windows 10 (build 10586), 64-bit edition
Version: 10.0
Platform: 64-bit system
CPU features: sse sse2 sse3 ssse3 sse4.1 sse4.2 avx aes pclmulqdq rdrnd
Settings dir: C:\Users\Gintz\AppData\Roaming\FileZilla\

Change History (2)

comment:1 Changed 3 years ago by Tim Kosse

Resolution: duplicate
Status: newclosed

Please use the search function.

comment:2 Changed 3 years ago by Dirk

Indeed it’s duplicate, but it still isn’t solved since more than 10 years!
Strange and unexpected behaviour of FileZilla, that makes files and folders inaccessible to FileZilla itself, I would call a bug.
At that point I was forced to use another FTP-client (WS_FTP Professional) that works properly.
Closing the ticket, because it’s duplicate is not a solution and other FTP-clients show, that the problem can and should be solved.

Last edited 3 years ago by Dirk (previous) (diff)
Note: See TracTickets for help on using tickets.