Opened 4 years ago

Closed 4 years ago

#10871 closed Bug report (rejected)

Critical file transfer error when download a file

Reported by: wyatts Owned by:
Priority: low Component: FileZilla Client
Keywords: Cc:
Component version: 3.18.0 Operating system type: Windows
Operating system version: windows7

Description

After changing root drive into B:\ by commnad CWD, I faced Critical file transfer error when download a file.

Reproduction step

  1. enter custom command "CWD B:\" (default A:\)
  2. refresh for list B:\ drive
  3. download one of files in B:\ drive root

Expectation
downloaded successfully

Actual Action
Critical file transfer error

Attaching log file

Attachments (1)

log.txt (1.8 KB ) - added by wyatts 4 years ago.

Download all attachments as: .zip

Change History (6)

by wyatts, 4 years ago

Attachment: log.txt added

comment:1 by Tim Kosse, 4 years ago

Priority: criticallow
Resolution: rejected
Status: newclosed

Custom commands are just that, custom commands. They bear no semantic meaning, especially not for independent transfer connections.

If you need to transfer files from a particular directory that isn't displayed in the remote file list, use the manual transfers dialog.

comment:2 by wyatts, 4 years ago

Thanks for the quick response.
I have some questions
After refreshing, the particular directory is displayed in the remote file list.
I think that it should work because I try to transfer files that exist in the remote file list.
Do you mean it is not allowed to transfer files that are not from default drive?
It seems to go to default drive when transfering files because new session is opened everytime transfering.
When I enter "A:\" into default remote directory In the site manager,I faced Critical file transfer error.

Is Manual transfer a unique solution when I try to transfer files after changing directory?

comment:3 by wyatts, 4 years ago

Resolution: rejected
Status: closedreopened

comment:4 by wyatts, 4 years ago

I've opend the issue to get the answer for the last comment that I left.
Thanks

comment:5 by Tim Kosse, 4 years ago

Resolution: rejected
Status: reopenedclosed

As can be seen by the reply to the PWD command, your server uses a Unix-style path syntax.

A:\ is a relative Unix-style path. Assuming for example the current path is /some/thing/, the result of CWD A:\ is /some/thing/A:\/ or, if the server treats backslashes like slashes as some servers do, /some/thing/A:/

That said, you cannot even enter relative paths into the default remote directory field, the Site Manager shows an error in that case.

Note: See TracTickets for help on using tickets.