Opened 4 years ago

Closed 4 years ago

#10813 closed Bug report (wontfix)

Updating to latest version trashed FZ installation

Reported by: DaveBerk Owned by:
Priority: normal Component: FileZilla Client
Keywords: Cc:
Component version: not available--see text for exe date Operating system type: Windows
Operating system version: Win 7 Pro

Description

Win 7 Pro. A few minutes ago, I clicked the "New version available" button from within FZ and followed the prompts. Things progressed in an orderly way until the prompt that told me a FileZilla exe was still running and that all running FZ apps should be exited before updating. There was no *visible* FZ exe running at that point, and I'm sorry to say (as I had had no trouble with preceding updates initiated AT START-UP of FZ and hence wasn't paying much attention to the update process) I don't recall what the choices were, but whatever I chose has resulted in my entire FZ installation being deleted except for the exe file (dated 2/29/16).

So this method of updating (from the BUTTON) appears to not kill the running FZ.

No back-up, my fault.

Change History (2)

comment:1 Changed 4 years ago by DaveBerk

A happy note: I just reinstalled FZ from scratch and discovered my settings were somehow preserved (registry?). That's a relief.

comment:2 Changed 4 years ago by Tim Kosse

Resolution: wontfix
Status: newclosed

In most cases, program freezes are being caused by deadlocks in third-party shell extensions that are loaded into FileZilla's address space as result of having called a shell function (e.g. getting a file icon).

The installer detects if the program is still running and displays a warning. If ignored, a corrupt installation can be the result, especially if any following errors are ignored.

Settings are stored independently of FileZilla in the user's profile directory at %APPDATA%/FileZilla

The installer does not touch the profile directories.

Note: See TracTickets for help on using tickets.