Opened 4 years ago

Closed 4 years ago

#10806 closed Bug report (wontfix)

Filezilla gives critical messages in the console while starting: IA__gtk_widget_set_size_request

Reported by: Markus Grob Owned by:
Priority: low Component: FileZilla Client
Keywords: size request widget start height width Cc:
Component version: 3.16.1 Operating system type: Linux
Operating system version: Suse Leap 42.1 with kernel 4.1.15-8

Description

I have downloaded FileZilla because I haven't found in in the repositories (3.16.1).
While starting from the console, I get the following lines, but in the GUI, I don't see an error:

markus@linux-vrvl:~/Downloads/FileZilla3/bin> ./filezilla

(filezilla:7978): Gtk-WARNING : Theme directory of theme oxygen has no size field

(filezilla:7978): Gtk-CRITICAL : IAgtk_widget_set_size_request: assertion 'height >= -1' failed

(filezilla:7978): Gtk-CRITICAL : IAgtk_widget_set_size_request: assertion 'width >= -1' failed

(filezilla:7978): Gtk-CRITICAL : IAgtk_widget_set_size_request: assertion 'height >= -1' failed

(filezilla:7978): Gtk-CRITICAL : IAgtk_widget_set_size_request: assertion 'width >= -1' failed

(filezilla:7978): Gtk-CRITICAL : IAgtk_widget_set_size_request: assertion 'height >= -1' failed

(filezilla:7978): Gtk-CRITICAL : IAgtk_widget_set_size_request: assertion 'width >= -1' failed


I have seen, that there is only one bug open with similiar behavier, but in an other context: https://trac.filezilla-project.org/ticket/9927

I have downloaded the package (FileZilla_3.16.1_x86_64-linux-gnu.tar.bz2 from sourceforge). Then I have unzipped it and started the binary as normal user in a subfolder of my homedirectory.

The package is linked against wxWidgets 3.0.3 and I'm using KDE Plasma 5.5.5

Change History (1)

comment:1 Changed 4 years ago by Tim Kosse

Resolution: wontfix
Status: newclosed

These messages come from GTK+ and could be caused either by GTK+ itself, the theming engine you are using or the wxWidgets toolkit.

In any case, it's not caused by FileZilla and, despite being labeled "CRITICAL", nothing bad happens. The program does not even terminate as one would expect from a critical error.

Note: See TracTickets for help on using tickets.