Opened 5 years ago

Closed 2 years ago

#10713 closed Bug report (fixed)

Text gets appended into <Server></Server>

Reported by: Sworddragon Owned by:
Priority: normal Component: FileZilla Client
Keywords: regression Cc:
Component version: 3.14.1 Operating system type: Linux
Operating system version: 4.3.3

Description

After upgrading FileZilla from version 3.12.0.2 to version 3.14.1 I'm noticing that sitemanager.xml gets malformed a bit:

  • Within a <Server></Server> entry at the end the text that is in <Name></Name> gets appended.
  • </Server> gets not indented correctly.

Attachments (1)

test.xml (182 bytes ) - added by Tim Kosse 5 years ago.
A completely valid XML file, with DTD.

Download all attachments as: .zip

Change History (11)

comment:1 by Tim Kosse, 5 years ago

Resolution: rejected
Status: newclosed

The XML is well-formed.

comment:2 by Sworddragon, 5 years ago

Maybe, but the text doesn't belong there.

comment:3 by Sworddragon, 5 years ago

Resolution: rejected
Status: closedreopened

comment:4 by Tim Kosse, 5 years ago

Resolution: rejected
Status: reopenedclosed

There is nothing wrong with the XML. It's in the format FileZilla understands and every standards-compliant XML parser in the whole universe can parse that document just fine.

comment:5 by Sworddragon, 5 years ago

Resolution: rejected
Status: closedreopened

It seems you don't understand what I'm meaning. Between those 2 FileZilla versions the file got changed with replacing 4 spaces with a tab. But somewhere between those 2 versions a mistake was made. The first is just a minor formation issue by placing a closing tag in the same line of another closing tag. It may not make the file invalid but since the file was designed to be intended to be well-formated this issue shouldn't exist there. The second issue is more problematic as between any <Server></Server> entry besides elements like <Host> or <Port> a non-whitespace text entry is written at the end of it. If there would be a DTD (I wonder why the file isn't linked against one) the XML would be even invalid. I hope it is now clear what I'm meaning.

comment:6 by Tim Kosse, 5 years ago

Resolution: rejected
Status: reopenedclosed

Indendation and well-formedness are independent. Indentation has no semantic meaning and is thus irrelevant.

Attached is an XML file with inline DTD that gets parses as completely valid despite having the perceived flaws you mention.

by Tim Kosse, 5 years ago

Attachment: test.xml added

A completely valid XML file, with DTD.

comment:7 by Sworddragon, 5 years ago

Resolution: rejected
Status: closedreopened

If this all is no issue can you tell me why <Server></Server> contains additional character data that matches what in <Name></Name> is? This makes no sense and because of the indentation issue at the same time it looks very obviously like an accident. Despite the fact that the indentation issue is still a valid bug, even if only a minor one.

comment:8 by Tim Kosse, 5 years ago

Resolution: rejected
Status: reopenedclosed

Backwards compatibility with older version, not all versions use the Name element.

The indentation issue is no issue because the indentation is completely irrelevant. It could just as well be completely absent.

comment:9 by Sworddragon, 2 years ago

Resolution: rejected
Status: closedreopened

comment:10 by Sworddragon, 2 years ago

Resolution: fixed
Status: reopenedclosed

With FileZilla 3.33 I did notice that the compatibility appending does not exist anymore. Also the wrong indentation does not appear anymore too so this issue is fixed.

Note: See TracTickets for help on using tickets.