Opened 4 years ago

Last modified 4 years ago

#10695 reopened Bug report

in Site Manager, can't search for site beginning with repeated letter

Reported by: Estelle Owned by:
Priority: normal Component: FileZilla Client
Keywords: Cc:
Component version: 3.12.02 Operating system type: Linux
Operating system version: Fedora 22

Description

on Linux (at least) when FileZilla is compiled against GTK3 (at least), searching the sites listed in Site Manager by typing the beginning of the site name does not work if the site name begins with a repeated letter. (presumably this affects repeated letters mid-string, too.)

Let's say your site list consists of the following (and you start with "aa" selected):
aa
sa
sb
sc
sd
ssabcdefg
sz

if you type "ssa" the result SHOULD be selecting "ssabcdefg", but instead it lands on "sa" ...

more specfically, when you type the first "s", the highlight moves to "sa" (as it should); when you type the second "s", the highlight moves to "sb" (the next entry starting with "s", rather than the entry starting with "ss"); and then when you type the "a", the highlight moves back to "sa". it seems that the search function ignores repeated letters :-(

Yes, this happens regardless of how quickly you type "ssa".

I am pretty sure this worked correctly in the past (specifically, I believe it worked correctly in Fedora 20, the last time FileZilla was compiled against GTK2 in that distro).

The search functionality is important when the site list includes hundreds.

Change History (5)

comment:1 Changed 4 years ago by Tim Kosse

This is independent of the used GTK version.

comment:2 Changed 4 years ago by Tim Kosse

Tree control prefix search is handled by wxWidgets.

Observed behavior is documented as intentional in the wx sources:

                // if the same character is typed multiple times then go to the
                // next entry starting with that character instead of searching
                // for an item starting with multiple copies of this character,
                // this is more useful and is how it works under Windows.

comment:3 Changed 4 years ago by Tim Kosse

Resolution: wontfix
Status: newclosed

comment:4 Changed 4 years ago by Estelle

Resolution: wontfix
Status: closedreopened

Please reconsider addressing this regression. I have at least two sites affected by this issue, and the "more useful" functionality described in the wx sources means that I would have to type "s" 16 and 17 times for the affected sites in order to get to them, rather than only twice. I have to connect to one of these sites on a regular basis, and that I can't search for it is disruptive to my process flow.

I was able to determine through testing that this regression occurred some time after the following version combination:
Fedora 21 / FileZilla 3.8.1 / wxGTK 2.8.12

The above is the version as originally released in Fedora 21. If I update to the latest version of FileZilla that became available during Fedora 21 (3.9.0), it requires wxGTK3 3.0.2, and the issue presents itself. It seems that the change was made between wxGTK 2 and wxGTK 3.

Also, the current behavior of the search functionality in Site Manager is inconsistent with the search functionality in the local and remote panes. Search in panes works as I would expect, and consistently with how search functions in other applications on Linux.

comment:5 Changed 4 years ago by Estelle

Suggested middle ground behavior:
If there is a site that starts with the repeated letters, take the user to that site when the user types the letter twice; if there is no site starting with those repeated letters, take the user to the next site starting with the letter.

Note: See TracTickets for help on using tickets.