Opened 4 years ago

Closed 4 years ago

#10680 closed Bug report (fixed)

IndexError: pop from empty list

Reported by: dacrhu Owned by:
Priority: normal Component: Other
Keywords: Cc:
Component version: Track Operating system type:
Operating system version:

Description

Hogyan reprodukálható

A GET művelet végrehajtása közben a(z) /attachment/ticket/10679/ erőforráson belső rendszerhiba történt.

(kérjük írjon további részleteket a hibáról)

A kérés paraméterei:

{u'action': u'new', 'path': u'10679/', 'realm': u'ticket'}

User agent: Mozilla/5.0 (X11; Fedora; Linux x86_64; rv:41.0) Gecko/20100101 Firefox/41.0

Rendszerinformáció

Rendszerinformáció nem elérhető

Engedélyezett bővítmények

Bővítmény információ nem elérhető

Python Traceback

Traceback (most recent call last):
  File "build/bdist.linux-x86_64/egg/trac/web/main.py", line 551, in _dispatch_request
    dispatcher.dispatch(req)
  File "build/bdist.linux-x86_64/egg/trac/web/main.py", line 264, in dispatch
    iterable=chrome.use_chunked_encoding)
  File "build/bdist.linux-x86_64/egg/trac/web/chrome.py", line 1110, in render_template
    encoding='utf-8')
  File "/usr/lib/python2.7/dist-packages/genshi/core.py", line 184, in render
    return encode(generator, method=method, encoding=encoding, out=out)
  File "/usr/lib/python2.7/dist-packages/genshi/output.py", line 58, in encode
    for chunk in iterator:
  File "/usr/lib/python2.7/dist-packages/genshi/output.py", line 350, in __call__
    for kind, data, pos in stream:
  File "/usr/lib/python2.7/dist-packages/genshi/output.py", line 829, in __call__
    for kind, data, pos in stream:
  File "/usr/lib/python2.7/dist-packages/genshi/output.py", line 669, in __call__
    for kind, data, pos in stream:
  File "/usr/lib/python2.7/dist-packages/genshi/output.py", line 774, in __call__
    for kind, data, pos in chain(stream, [(None, None, None)]):
  File "/usr/lib/python2.7/dist-packages/genshi/output.py", line 594, in __call__
    for ev in stream:
  File "/usr/lib/python2.7/dist-packages/genshi/core.py", line 289, in _ensure
    for event in stream:
  File "/usr/lib/python2.7/dist-packages/genshi/core.py", line 289, in _ensure
    for event in stream:
  File "build/bdist.linux-x86_64/egg/trac/web/chrome.py", line 1307, in _strip_accesskeys
    for kind, data, pos in stream:
  File "/usr/lib/python2.7/dist-packages/genshi/core.py", line 289, in _ensure
    for event in stream:
  File "build/bdist.linux-x86_64/egg/trac/web/chrome.py", line 1296, in _generate
    for kind, data, pos in stream:
  File "/usr/lib/python2.7/dist-packages/genshi/core.py", line 289, in _ensure
    for event in stream:
  File "/usr/lib/python2.7/dist-packages/genshi/core.py", line 289, in _ensure
    for event in stream:
  File "/usr/lib/python2.7/dist-packages/genshi/filters/transform.py", line 706, in _unmark
    for mark, event in stream:
  File "/usr/lib/python2.7/dist-packages/genshi/filters/transform.py", line 1101, in __call__
    for mark, event in stream:
  File "/usr/lib/python2.7/dist-packages/genshi/filters/transform.py", line 118, in __iter__
    event = self.stream.next()
  File "/usr/lib/python2.7/dist-packages/genshi/filters/transform.py", line 734, in __call__
    for mark, event in stream:
  File "/usr/lib/python2.7/dist-packages/genshi/filters/transform.py", line 702, in _mark
    for event in stream:
  File "/usr/lib/python2.7/dist-packages/genshi/template/base.py", line 618, in _include
    for event in stream:
  File "/usr/lib/python2.7/dist-packages/genshi/template/markup.py", line 378, in _match
    ctxt, start=idx + 1, **vars):
  File "/usr/lib/python2.7/dist-packages/genshi/template/markup.py", line 378, in _match
    ctxt, start=idx + 1, **vars):
  File "/usr/lib/python2.7/dist-packages/genshi/template/markup.py", line 326, in _match
    for event in stream:
  File "/usr/lib/python2.7/dist-packages/genshi/template/base.py", line 558, in _flatten
    for kind, data, pos in stream:
  File "/usr/lib/python2.7/dist-packages/genshi/core.py", line 289, in _ensure
    for event in stream:
  File "/usr/lib/python2.7/dist-packages/genshi/path.py", line 588, in _generate
    subevent = next()
  File "/usr/lib/python2.7/dist-packages/genshi/template/base.py", line 618, in _include
    for event in stream:
  File "/usr/lib/python2.7/dist-packages/genshi/template/markup.py", line 315, in _strip
    event = next()
  File "/usr/lib/python2.7/dist-packages/genshi/template/base.py", line 558, in _flatten
    for kind, data, pos in stream:
  File "/usr/lib/python2.7/dist-packages/genshi/core.py", line 289, in _ensure
    for event in stream:
  File "/usr/lib/python2.7/dist-packages/genshi/path.py", line 588, in _generate
    subevent = next()
  File "/usr/lib/python2.7/dist-packages/genshi/template/base.py", line 618, in _include
    for event in stream:
  File "/usr/lib/python2.7/dist-packages/genshi/template/markup.py", line 315, in _strip
    event = next()
  File "/usr/lib/python2.7/dist-packages/genshi/template/base.py", line 558, in _flatten
    for kind, data, pos in stream:
  File "/usr/lib/python2.7/dist-packages/genshi/filters/i18n.py", line 178, in _generate
    for event in msgbuf.translate(gettext(msgbuf.format())):
  File "/usr/lib/python2.7/dist-packages/genshi/filters/i18n.py", line 1051, in translate
    events = self.events[order].pop(0)
IndexError: pop from empty list

Change History (1)

comment:1 Changed 4 years ago by Tim Kosse

Resolution: fixed
Status: newclosed

Seems to be this bug: http://trac.edgewall.org/ticket/11184

Caused by this one: http://genshi.edgewall.org/ticket/566

And requested for backport in https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=775746

I have manually applied the changeset, it should work now.

Note: See TracTickets for help on using tickets.