Opened 4 years ago

Closed 4 years ago

#10598 closed Bug report (duplicate)

open servermanager --> an assertion failed

Reported by: hh Owned by:
Priority: normal Component: FileZilla Client
Keywords: Cc:
Component version: Operating system type: Linux
Operating system version:

Description

I can't open the server manager under Archlinux with LXQT. Here is what is reported:

ASSERT INFO:
buildinfo.cpp(118): assert "*version >= '0' && *version <= '9'" failed in ConvertToVersionNumber().

BACKTRACE:
[1] wxNavigationEnabled<wxWindow>::AcceptsFocusFromKeyboard() const
[2] wxString wxString::Format<wxString, wxString>(wxFormatString const&, wxString, wxString)
[3] wxString wxString::Format<wxString, wxString>(wxFormatString const&, wxString, wxString)
[4] wxString wxString::Format<wxString, wxString>(wxFormatString const&, wxString, wxString)
[5] wxNavigationEnabled<wxListCtrlBase>::AcceptsFocusRecursively() const
[6] wxAppConsoleBase::CallEventHandler(wxEvtHandler*, wxEventFunctor&, wxEvent&) const
[7] wxEvtHandler::ProcessEventIfMatchesId(wxEventTableEntryBase const&, wxEvtHandler*, wxEvent&)
[8] wxEventHashTable::HandleEvent(wxEvent&, wxEvtHandler*)
[9] wxEvtHandler::TryHereOnly(wxEvent&)
[10] wxEvtHandler::ProcessEventLocally(wxEvent&)
[11] wxEvtHandler::ProcessEvent(wxEvent&)
[12] wxWindowBase::TryAfter(wxEvent&)
[13] wxEvtHandler::SafelyProcessEvent(wxEvent&)
[14] wxToolBarBase::OnLeftClick(int, bool)
[15] g_signal_emit_valist
[16] g_signal_emit_by_name
[17] g_signal_emit_valist
[18] g_signal_emit
[19] g_closure_invoke
[20] g_signal_emit_valist
[21] g_signal_emit
[22] g_closure_invoke
[23] g_signal_emit_valist
[24] g_signal_emit
[25] gtk_propagate_event
[26] gtk_main_do_event
[27] g_main_context_dispatch
[28] g_main_loop_run
[29] gtk_main
[30] wxGUIEventLoop::DoRun()
[31] wxEventLoopBase::Run()
[32] wxAppConsoleBase::MainLoop()
[33] wxEntry(int&, wchar_t)
[34] libc_start_main

here is the program info:
FileZilla Client


Version: 3.12.0.2

Build information:

Compiled for: x86_64-unknown-linux-gnu
Compiled on: x86_64-unknown-linux-gnu
Build date: 2015-07-11
Compiled with: gcc (GCC) 5.1.0
Compiler flags: -march=x86-64 -mtune=generic -O2 -pipe -fstack-protector-strong --param=ssp-buffer-size=4 -Wall -g -std=gnu++11

Linked against:

wxWidgets: 3.0.2
GnuTLS: 3.4.2
SQLite: 3.8.10.2

Operating system:

Name: Linux 4.1.2-2-ARCH x86_64
Version: 4.1
CPU features: sse sse2 sse3 ssse3 sse4.1 sse4.2 avx aes pclmulqdq
Settings dir: /home/hannes/.config/filezilla/

Change History (3)

comment:1 Changed 4 years ago by hh

Priority: blockernormal

comment:2 Changed 4 years ago by hh

I can now open the server manager, since accepting (or dismissing not sure -- okay or cancel) the error message does not seem to appear anymore.

comment:3 Changed 4 years ago by Tim Kosse

Resolution: duplicate
Status: newclosed

Duplicate of #10579

Note: See TracTickets for help on using tickets.