Opened 5 years ago

Closed 5 years ago

#10236 closed Bug report (fixed)

Unknown Certificate with many SAN entries missing "Always trust certificate..."

Reported by: surr34l Owned by:
Priority: high Component: FileZilla Client
Keywords: unknown certificate san hostname checkbox missing always trust future sessions Cc:
Component version: Operating system type: Windows
Operating system version: 7 SP1 and 8.1 Update 1 x64

Description

Since updating FileZilla Client from v3.10.0.2 to v3.10.1.1, when FileZilla prompts for my 'Unknown certificate' it no longer shows the checkbox for 'Always trust certificate for future sessions'.

Certificate is within the Validity period and host address matches the SAN. This is self-signed, with many SAN entries to cover all accessible hostnames the FTP is accessed from internally and externally.

I can only assume because of the number of SAN in the list, it pushes the checkbox off screen, and doesn't have anything to do with any problem or expiration of the certificate.

Only other issues I found similar to this were expired certificates where the checkbox was visible, but not selectable.

For me, it's not even visible.

Attachments (2)

Unknown_Certificate_ERROR_v3.10.1.1.png (42.8 KB) - added by surr34l 5 years ago.
Missing checkbox in 3.10.1.1
Unknown_Certificate_v3.10.0.2.png (33.1 KB) - added by surr34l 5 years ago.
Works as intended in 3.10.0.2

Download all attachments as: .zip

Change History (6)

Changed 5 years ago by surr34l

Missing checkbox in 3.10.1.1

Changed 5 years ago by surr34l

Works as intended in 3.10.0.2

comment:1 Changed 5 years ago by Tim Kosse

Priority: normalhigh

comment:2 Changed 5 years ago by Tim Kosse

Workaround: Pressing Alt+A selects the checkbox even if pushed outside the visible area.

comment:3 Changed 5 years ago by surr34l

Thank you. A much easier workaround than editing the XML file. Kind of kicking myself for not thinking of that but was in the middle of a lengthy upgrade from Win XP to 8.1 for a customer. Thanks again. That should tide me over until an update is available.

comment:4 Changed 5 years ago by Tim Kosse

Resolution: fixed
Status: newclosed

A fix for this is in the repository.

Please test the upcoming beta version of FileZilla which will be released this weekend.

Note: See TracTickets for help on using tickets.