Opened 4 years ago

Closed 4 years ago

#10223 closed Bug report (duplicate)

Client 3.10.1.1 failed to retrieve directory listing. Worked before this version on this site.

Reported by: Charlie Owned by:
Priority: normal Component: FileZilla Client
Keywords: MLSD failed Cc:
Component version: Operating system type: Windows
Operating system version: Win7 Pro 64

Description

Directory listing worked before on this site. Works from command line ftp.
FileZilla Client


Version: 3.10.1.1

Build information:

Compiled for: i686-w64-mingw32
Compiled on: x86_64-unknown-linux-gnu
Build date: 2015-02-01
Compiled with: i686-w64-mingw32-gcc (GCC) 4.9.1
Compiler flags: -g -O2 -Wall -g -fexceptions -std=gnu++11

Linked against:

wxWidgets: 3.0.3
GnuTLS: 3.2.21
SQLite: 3.8.8.2

Operating system:

Name: Windows 7 (build 7601, Service Pack 1), 64-bit edition
Version: 6.1
Platform: 64-bit system

Log:
Status: Resolving address of ftp.kotan.com
Status: Connecting to 50.31.3.169:21...
Status: Connection established, waiting for welcome message...
Status: Initializing TLS...
Status: Verifying certificate...
Status: TLS connection established.
Status: Server does not support non-ASCII characters.
Status: Connected
Status: Retrieving directory listing...
Command: PWD
Response: 257 "/" is your current location
Command: TYPE I
Response: 200 TYPE is now 8-bit binary
Command: PASV
Response: 227 Entering Passive Mode (50,31,3,169,138,83)
Command: MLSD
Error: Connection timed out
Error: Failed to retrieve directory listing

Change History (2)

comment:1 Changed 4 years ago by Charlie

Investigation: ftp site certificate expired. Client provides cert dialog, but OKing results in the error. Selecting insecure FTP resolves issue. Perhaps clear error message that TLS cannot work with expired certificate would help.

comment:2 Changed 4 years ago by Tim Kosse

Resolution: duplicate
Status: newclosed
Note: See TracTickets for help on using tickets.