Opened 6 years ago

Closed 4 years ago

#10212 closed Bug report (rejected)

failed to write filezilla.xml file

Reported by: mustafa@… Owned by:
Priority: normal Component: FileZilla Client
Keywords: error xml write Cc:
Component version: Operating system type: Windows
Operating system version: server 2012 r2

Description (last modified by Tim Kosse)

we are using active directory and roaming profile, because of this %appdata% is
fileserver\appdata$\Administrator\AppData\Roaming

even the domain admin, which has a local admin rights on the machine where filezilla is runnign is giving

error writing xml file
could not write
fileserver\appdata$\Administrator\AppData\Roaming\filezilla\filezilla.xml": failed to write xml file error

we don not have any problem with all the other software we use.

Change History (7)

comment:1 by mustafa@…, 6 years ago

the version we are using is latest 3.10.1.1

comment:2 by Tim Kosse, 6 years ago

Status: newmoreinfo

Do you use any third-party programs that fiddle around in FileZilla's settings directory? E.g. virus scanners, file synchronization tools, backup tools or the likes.

If so, what happens if you deactivate those for a test?

comment:3 by Nicrammarcin, 6 years ago

Status: moreinfonew

Confirmed. I'm trying to use Server 2012 r2 as a file server. With Server 2008 R2 everything is fine, but with 2012 R2 and path in fzdefaults.xml set to z:\filezilla (where z: is a mapped drive from server 2012 r2
fileserver\users\user). Everytime I'm closing Filezilla client eroor occurs "Could not write "z:\filezilla\filezilla.xml":Failed to write xml file. I don't have virus scanner or backup tools. I have full domain administrator rights everywhere. When I set local path to C:\temp\filezilla or to network drive mapped from Server 2008 R2, everything is OK.

comment:4 by Tim Kosse, 5 years ago

Status: newmoreinfo

Confirmed [using] Server 2012 r2 as a file server. With Server 2008 R2 everything is fine

This is odd. What does Server 2012 r2 do differently?

comment:5 by marcphilips, 4 years ago

Status: moreinfonew

Anybody found a solution for this?
We checked file permissions, share permissions(set all to full control) removed quota manager . no luck
And when we use procmon to capture the filezilla write process the issue cannot be reproduced.

comment:6 by marcphilips, 4 years ago

As this issue seems to be related to the save to temp ~ file and then renaming it while still being locked by the thirdparty anti-virus: i would suggest to add a 0,5 sec sleep in that code in the future.

comment:7 by Tim Kosse, 4 years ago

Description: modified (diff)
Resolution: rejected
Status: newclosed

You need to fix your broken virus scanner so that it does not lock files. Contact your AV vendor for further assistance.

Quite frankly: If it scans using an external process, it's not secure. Between data being written to file and then scanned by the virus scanner there's ample of time for it to be executed. And said data could be a virus...
A proper virus scanner intercepts file I/O using a kernel mode driver that, except for the expected reduction in performance, behaves otherwise completely transparent towards harmless applications.

Note: See TracTickets for help on using tickets.