Opened 14 years ago

Last modified 12 years ago

#1017 closed Bug report

FTP cut short

Reported by: usher50 Owned by: Alexander Schuch
Priority: normal Component: FileZilla Client
Keywords: Cc: usher50, Alexander Schuch, youngjan, peterpramb
Component version: Operating system type:
Operating system version:

Description

In downloading a 26 MB file from an FTP site the
process starts and then terminates with only 2 to 4
MB downloaded. It does not report any problem with
the download and implies that the entire download was
successful.

Tried this many times but the result was the same.

I immediately tried accessing the FTP site with IE 6
and I sucessfully downloaded the file, hence I don't
believe that the site was having a problem.

I also had the same problem about 10 days ago.

Change History (6)

comment:1 Changed 14 years ago by youngjan

System: We are having a simmiliar problem. We are using the
Titan FTP (Windows) Server and we connect using the
FileZilla 2.2.17, however, were experiencing the problem
for the past 1 year also with earlier versions of
FileZilla. We connect wia port 990 with the implicit SSL
encryption. The probelm doesn't happen while using the Cute
FTP Client.

Problem: When we download files (different sizes, even
small JPG's) the download seems complete (the quee gets
empty), however, when you check the downloaded file it is
corrupted and smaller than the original one on the server.
Than later on you can download the rest of file with the
resume function. The problem is that the download seems OK,
but it is not!

comment:2 Changed 14 years ago by youngjan

Sorry, Please replace word 'download' with 'upload' in my
previous comment. We are experiencing these problems only
with uploads.

comment:3 Changed 14 years ago by peterpramb

Same here. When downloading an Excel file (157184b) - of
course in binary mode - from an ftp server, it is smaller
then the original and corrupted. When downloading with
ncftp, it has the correct size.

We have an old installation (2.2.11) where this problem
doesn't exist. Using another installation (2.2.12c, 2.2.18)
shows the problem again.

comment:4 Changed 14 years ago by peterpramb

I should add that we are using a ftp proxy (frox). Without
the ftp proxy, the downloaded file has the correct size.

The mentioned download via ncftp also used the same ftp proxy.

comment:5 Changed 13 years ago by Alexander Schuch

Can you please try current version of FileZilla 2 or even FileZilla 3 beta, which
unforunately doesn't support FTP proxies yet.

comment:6 Changed 12 years ago by Alexander Schuch

FileZilla 2 is not supported anymore and FileZilla 3 has proxy support implemented for quite some time already. As FileZilla 3 is a nearly complete re-write, the issue might be fixed already. As there hasn't been any answer here for more than one year, I assume that the problem is solved.

Closing this bug report. Feel free to re-open it if the problem persists in most recent FileZilla 3.

Note: See TracTickets for help on using tickets.