Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#10099 closed Bug report (fixed)

"An invalid index was passed to wxDisplay" assertion failed when overwriting file

Reported by: Sebastiaan Owned by:
Priority: normal Component: FileZilla Client
Keywords: overwrite assertion wxWidgets wxGTK wxDisplay Cc:
Component version: Operating system type: Linux
Operating system version:

Description

When I try to overwrite a file (either because I'm uploading a file that already exists on the server, or the other way around), I get the following notification:

An assertion failed!
./src/common/dpycmn.cpp(119): assert "n < GetCount()" failed in wxDisplay(): An invalid index was passed to wxDisplay

(backtrace attached)

After clicking continue (twice), the up/download seems to further work as expected.

I think this was introduced when switching to wxWidgets 3, which was done with FileZilla 3.9.

I am using FileZilla 3.10.0.2 on Arch Linux x86_64, and there is at least one Arch user that has the same problem (report). There is also a report from a Debian user with the same problem, also with FileZilla 3.9.

Attachments (2)

FileZilla-wxDisplay-backtrace.txt (1.3 KB) - added by Sebastiaan 5 years ago.
assertion failed backtrace
xrandr-output.txt (1.3 KB) - added by Sebastiaan 5 years ago.

Download all attachments as: .zip

Change History (9)

Changed 5 years ago by Sebastiaan

assertion failed backtrace

comment:1 Changed 5 years ago by Tim Kosse

Status: newmoreinfo

How many displays do you have attached to your system?

Which desktop environment do you use?

Are you using X11, Wayland or Mir?

comment:2 Changed 5 years ago by Sebastiaan

Status: moreinfonew

I have 2 displays attached to my system (to my Nvidia graphics card, using its proprietary drivers, v 343.36).

I use Openbox, but I've also tested it in GNOME and the issue is present there too.

I'm using X11 (1.16.3).

comment:3 Changed 5 years ago by Sebastiaan

When I disable my second monitor, the error disappears!

Is there anything else I can do to help diagnose the problem? Because the problem seems related to the display setup, I've included the output of 'xrandr', so you know the exact setup I use.

Changed 5 years ago by Sebastiaan

Attachment: xrandr-output.txt added

comment:4 Changed 5 years ago by Tim Kosse

Before the file exists dialog is shown, FileZilla gets the dimensions of the display the window will be displayed on and potentially shortens the path/filename to prevent the window from becoming too big.

I've added a check to return early in case the current display index could not be obtained to silence this assertion.

The root cause, why getting the display index fails, is unknown yet.

Because the problem seems related to the display setup, I've included the output of 'xrandr', so you know the exact setup I use.

If I understand the output correctly, your slightly smaller secondary display is to the left of the primary display, more or less vertically centered.

comment:5 Changed 5 years ago by Tim Kosse

I managed to reproduce it. Using a debug build of wxWidgets I got another assert: "ClientToScreen failed on unrealized window"

comment:6 Changed 5 years ago by Tim Kosse

Resolution: fixed
Status: newclosed

Fixed in the repository.

comment:7 in reply to:  6 Changed 5 years ago by Sebastiaan

If I understand the output correctly, your slightly smaller secondary display is to the left of the primary display, more or less vertically centered.

Yes, that's right.

Fixed in the repository.

I can confirm that it is fixed. Thanks so much for the quick response!

Note: See TracTickets for help on using tickets.