Opened 5 years ago

Closed 5 years ago

#10023 closed Bug report (duplicate)

FileZilla times out when retrieving directory listing

Reported by: Complainer Owned by:
Priority: normal Component: FileZilla Client
Keywords: Cc:
Component version: Operating system type: Windows
Operating system version: Win 7 Ultimate SP1

Description

Status: Resolving address of ftp
Status: Connecting to ....
Status: Connection established, waiting for welcome message...
Status: Initializing TLS...
Status: Verifying certificate...

This version of Filezilla is telling me "Unknown sertificate" on remote server

Status: TLS connection established.
Status: Server does not support non-ASCII characters.
Status: Connected
Status: Retrieving directory listing of "/public_html"...

hangs here for like 10-15 secs

Command: CWD /public_html
Response: 250 OK. Current directory is /public_html
Command: PWD
Response: 257 "/public_html" is your current location
Command: TYPE I
Response: 200 TYPE is now 8-bit binary
Command: PASV
Response: 227 Entering Passive Mode (212,125,204,217,125,118)
Command: MLSD
Error: Connection timed out
Error: Failed to retrieve directory listing

It stops here..

FileZilla Client


Version: 3.10.0

Build information:

Compiled for: i686-w64-mingw32
Compiled on: x86_64-unknown-linux-gnu
Build date: 2015-01-07
Compiled with: i686-w64-mingw32-gcc (GCC) 4.9.1
Compiler flags: -g -O2 -Wall -g -fexceptions -std=gnu++11

Linked against:

wxWidgets: 3.0.3
GnuTLS: 3.2.20
SQLite: 3.8.7.2

Operating system:

Name: Windows 7 (build 7601, Service Pack 1), 64-bit edition
Version: 6.1
Platform: 64-bit system

Previous version worked fine, then desided to upgrade after having done my transfers, and it is now borked.
In advance, Thanks for fixing.

Change History (6)

comment:1 Changed 5 years ago by Iain Mackintosh

I'm getting the same problem with 3.10.0 and 3.10.0.1. After many timeouts, I now have half-deleted folders on my site, so could use some quick help.

comment:2 Changed 5 years ago by Matt Collins

I have the same problem after upgrading to 3.10.0.0 and 3.10.0.1.

I posted this information also under Bug Report #10026 and am reporting it here, too, because these seem to be duplicate tickets and I don't know which one will be seen first.

*
Here's the info from the About FileZilla screen:
*
FileZilla Client

Version: 3.10.0.1

Build information:

Compiled for: i686-w64-mingw32

Compiled on: x86_64-unknown-linux-gnu
Build date: 2015-01-12
Compiled with: i686-w64-mingw32-gcc (GCC) 4.9.1
Compiler flags: -g -O2 -Wall -g -fexceptions -std=gnu++11

Linked against:

wxWidgets: 3.0.3

GnuTLS: 3.2.20
SQLite: 3.8.7.2

Operating system:

Name: Windows 7 (build 7601, Service Pack 1), 64-bit edition

Version: 6.1
Platform: 64-bit system

*

*
I set the debug level to 3-Verbose. Here's the log:
*
Status: Resolving address of ftp.interbit.com
Status: Connecting to 71.18.7.135:21...
Status: Connection established, waiting for welcome message...
Status: Initializing TLS...
Status: Verifying certificate...
Status: TLS connection established.
Status: Server does not support non-ASCII characters.
Status: Connected
Trace: Measured latency of 38 ms
Status: Retrieving directory listing of "/interbit"...
Trace: CFtpControlSocket::SendNextCommand()
Trace: CFtpControlSocket::ChangeDirSend()
Command: CWD /interbit
Trace: CFtpControlSocket::OnReceive()
Response: 550 /interbit: No such file or directory
Trace: CFtpControlSocket::ResetOperation(2)
Trace: CControlSocket::ResetOperation(2)
Trace: CFtpControlSocket::ParseSubcommandResult(2)
Trace: CFtpControlSocket::ListSubcommandResult()
Trace: CFtpControlSocket::SendNextCommand()
Trace: CFtpControlSocket::ChangeDirSend()
Command: PWD
Trace: CFtpControlSocket::OnReceive()
Response: 257 "/" is the current directory
Trace: CFtpControlSocket::ResetOperation(0)
Trace: CControlSocket::ResetOperation(0)
Trace: CFtpControlSocket::ParseSubcommandResult(0)
Trace: CFtpControlSocket::ListSubcommandResult()
Trace: CFtpControlSocket::SendNextCommand()
Trace: CFtpControlSocket::TransferSend()
Command: TYPE I
Trace: CFtpControlSocket::OnReceive()
Response: 200 Type set to I
Trace: CFtpControlSocket::TransferParseResponse()
Trace: CFtpControlSocket::SendNextCommand()
Trace: CFtpControlSocket::TransferSend()
Command: PASV
Trace: CFtpControlSocket::OnReceive()
Response: 227 Entering Passive Mode (71,18,7,135,197,251).
Trace: CFtpControlSocket::TransferParseResponse()
Trace: CFtpControlSocket::SendNextCommand()
Trace: CFtpControlSocket::TransferSend()
Command: MLSD
Error: The data connection could not be established: ECONNREFUSED - Connection refused by server
Trace: CTransferSocket::TransferEnd(3)
Trace: CFtpControlSocket::TransferEnd()
Error: Connection timed out
Trace: CFtpControlSocket::ResetOperation(2114)
Trace: CControlSocket::ResetOperation(2114)
Trace: CFtpControlSocket::ResetOperation(2114)
Trace: CControlSocket::ResetOperation(2114)
Error: Failed to retrieve directory listing
*

*

Other Comments:

*

  1. I am able to connect to this server using FTP from the Windows Command Prompt, from my iPad, and my iPhone.
  1. I also had a message that the certificate was unknown and overrode it, saying to trust it in the future.
  1. I rebooted my computer.
  1. I don't know what version I upgraded from, but the first upgrade was to 3.10.0.0 and the second upgrade was to 3.10.0.1.
  1. I am able to connect to an FTP site within my corporate firewall.
  1. I have confirmed I'm using the correct password.


comment:3 Changed 5 years ago by Matt Collins

Status: newmoreinfo

comment:4 Changed 5 years ago by Tim Kosse

Priority: criticalnormal

comment:5 Changed 5 years ago by Iain Mackintosh

Operating system version: Win 7 Ultimate SP1
Status: moreinfonew

I retried my site updates using 3.10.0.1 after noticing the priority change by codesquid. Everything worked fine and I was able to update 4 other sites without problems. It would be good to know if this problem is now fully fixed or if it could recur intermittently. Also, what caused it?

comment:6 Changed 5 years ago by Tim Kosse

Resolution: duplicate
Status: newclosed

Duplicate of #9995

Note: See TracTickets for help on using tickets.