Opened 5 years ago

Closed 5 years ago

#10015 closed Bug report (duplicate)

Won't connect at all after latest update

Reported by: jkantor Owned by:
Priority: normal Component: FileZilla Client
Keywords: Cc:
Component version: Operating system type: Windows
Operating system version: windows 7 home 64

Description

To any ftp server.

Change History (6)

comment:1 Changed 5 years ago by jkantor

3.10

3.9.0.6 works fine.

comment:2 Changed 5 years ago by Matt Collins

I have the same problem after upgrading to 3.10.0.0 and 3.10.0.1.

I posted this information also under Bug Report #10026 and am reporting it here, too, because these seem to be duplicate tickets and I don't know which one will be seen first.

*
Here's the info from the About FileZilla screen:
*
FileZilla Client

Version: 3.10.0.1

Build information:

Compiled for: i686-w64-mingw32

Compiled on: x86_64-unknown-linux-gnu
Build date: 2015-01-12
Compiled with: i686-w64-mingw32-gcc (GCC) 4.9.1
Compiler flags: -g -O2 -Wall -g -fexceptions -std=gnu++11

Linked against:

wxWidgets: 3.0.3

GnuTLS: 3.2.20
SQLite: 3.8.7.2

Operating system:

Name: Windows 7 (build 7601, Service Pack 1), 64-bit edition

Version: 6.1
Platform: 64-bit system

*

*
I set the debug level to 3-Verbose. Here's the log:
*
Status: Resolving address of ftp.interbit.com
Status: Connecting to 71.18.7.135:21...
Status: Connection established, waiting for welcome message...
Status: Initializing TLS...
Status: Verifying certificate...
Status: TLS connection established.
Status: Server does not support non-ASCII characters.
Status: Connected
Trace: Measured latency of 38 ms
Status: Retrieving directory listing of "/interbit"...
Trace: CFtpControlSocket::SendNextCommand()
Trace: CFtpControlSocket::ChangeDirSend()
Command: CWD /interbit
Trace: CFtpControlSocket::OnReceive()
Response: 550 /interbit: No such file or directory
Trace: CFtpControlSocket::ResetOperation(2)
Trace: CControlSocket::ResetOperation(2)
Trace: CFtpControlSocket::ParseSubcommandResult(2)
Trace: CFtpControlSocket::ListSubcommandResult()
Trace: CFtpControlSocket::SendNextCommand()
Trace: CFtpControlSocket::ChangeDirSend()
Command: PWD
Trace: CFtpControlSocket::OnReceive()
Response: 257 "/" is the current directory
Trace: CFtpControlSocket::ResetOperation(0)
Trace: CControlSocket::ResetOperation(0)
Trace: CFtpControlSocket::ParseSubcommandResult(0)
Trace: CFtpControlSocket::ListSubcommandResult()
Trace: CFtpControlSocket::SendNextCommand()
Trace: CFtpControlSocket::TransferSend()
Command: TYPE I
Trace: CFtpControlSocket::OnReceive()
Response: 200 Type set to I
Trace: CFtpControlSocket::TransferParseResponse()
Trace: CFtpControlSocket::SendNextCommand()
Trace: CFtpControlSocket::TransferSend()
Command: PASV
Trace: CFtpControlSocket::OnReceive()
Response: 227 Entering Passive Mode (71,18,7,135,197,251).
Trace: CFtpControlSocket::TransferParseResponse()
Trace: CFtpControlSocket::SendNextCommand()
Trace: CFtpControlSocket::TransferSend()
Command: MLSD
Error: The data connection could not be established: ECONNREFUSED - Connection refused by server
Trace: CTransferSocket::TransferEnd(3)
Trace: CFtpControlSocket::TransferEnd()
Error: Connection timed out
Trace: CFtpControlSocket::ResetOperation(2114)
Trace: CControlSocket::ResetOperation(2114)
Trace: CFtpControlSocket::ResetOperation(2114)
Trace: CControlSocket::ResetOperation(2114)
Error: Failed to retrieve directory listing
*

*

Other Comments:

*

  1. I am able to connect to this server using FTP from the Windows Command Prompt, from my iPad, and my iPhone.
  1. I also had a message that the certificate was unknown and overrode it, saying to trust it in the future.
  1. I rebooted my computer.
  1. I don't know what version I upgraded from, but the first upgrade was to 3.10.0.0 and the second upgrade was to 3.10.0.1.
  1. I am able to connect to an FTP site within my corporate firewall.
  1. I have confirmed I'm using the correct password.


comment:3 Changed 5 years ago by Tim Kosse

Priority: criticalnormal
Status: newmoreinfo

@Original poster: Please provide a log of the connection attempt.

@mcollins: How do you know you have the same problem if the original report doesn't even show a log? You can at most be certain of having the same symptoms.

comment:4 Changed 5 years ago by Matt Collins

Status: moreinfonew

Technically, you're right, of course. But with 30 years of programming experience and experience interpreting customers' ways of describing problems, it was a judgment I made, based on looking at the problem summary, the version number, and the recent spate of reported problems with these last two versions, all with similar descriptions. I thought this was probably the same thing and was trying to provide more information so that the programmers could look into it further and figure out whether or not that is the case. If I knew for sure it was the same thing then I guess I would have found the source of the problem and perhaps could tell the programmers how to fix it.

comment:5 Changed 5 years ago by kingsway7

I have identical problem - won't display the folders - stops at "MLSD"

error message:

Error: Connection timed out
Error: Failed to retrieve directory listing

comment:6 Changed 5 years ago by Tim Kosse

Resolution: duplicate
Status: newclosed

Duplicate of #9995

Note: See TracTickets for help on using tickets.