Ticket #4328 (closed Bug report: fixed)

Opened 6 years ago

Last modified 8 months ago

remote file edit problem when editing multiple files with same name but in different folder

Reported by: sudarsh Owned by:
Priority: high Component: FileZilla Client
Keywords: view/edit remote file overwrites wrong file on remote location Cc:
Operating system type: Windows Operating system version: Windows XP SP3

Description

I have to edit many files with same name that are on different folders. eg: /dev/web.config, /live/web.config, etc. The problem is that after completed editing the first file and uploading it and then editing the second file and saving it triggers two "file has changed" dialog boxes. and if saved, the first remote file is overwritten with the second file.

FileZilla client version: 3.2.2.1
System: Windows XP SP3 on Intel P4 3.0GHz

Change History

  Changed 6 years ago by codesquid

  • status changed from new to moreinfo

Please describe the exact steps needed to reproduce this issue.

  Changed 5 years ago by sudarsh

  • status changed from moreinfo to new

Finally I found how to reproduce the problem.

Folder Structure
/MainFolder

|_ Folder1
| |_ web.config
|_ Folder2

|_ web.config

1) Connect to a remote server (Above folder structure is expected. Foldername and Filename can vary)

2) Edit web.config file in Folder1 and save it (I use Notepad). Then upload file back to the server when prompted.

3) Then edit the web.config file in the Folder2 and close it without saving.

4) You should now see a file changed dialog box pointing to the previous edit ie: Folder1. But if we upload the file back to the server, the web.config file in Folder1 will be replaced with the web.config file in Folder2.

follow-up: ↓ 4   Changed 5 years ago by codesquid

  • status changed from new to moreinfo

3.2.2.1 is outdated. Does this still happen with 3.2.3?

in reply to: ↑ 3   Changed 5 years ago by sudarsh

  • status changed from moreinfo to new

Replying to codesquid:

3.2.2.1 is outdated. Does this still happen with 3.2.3?

Yes. When I posted the issue I was using 3.2.2.1 but now I'm updated to 3.2.3.1
But the problem remain the same.

  Changed 5 years ago by codesquid

  • status changed from new to moreinfo

Unfortunately I cannot reproduce this issue. Which editor are you using? Try using something simple as plain old notepad.

  Changed 5 years ago by sudarsh

  • status changed from moreinfo to new

I can recreate it everytime. I'll give you a bit more details.
Again the folder structure is similar as below.

/mywebsite/dev.myweb/web.config
/mywebsite/live.myweb/web.config

(I think the folder "mywebsite" is in the root not sure. I do not have the issue on a different server. So not sure what folder structure is triggering it.)

step 1. Open FZ. connect to the server. (I use the stored connection in site manager)
step 2. "view/edit" /mywebsite/dev.myweb/web.config
step 3. Save file and close Notepad or whatever your editor is.
step 4. "File has changed" dialog box will appear in FZ. Click "Yes". DO NOT check "Finish editing and delete local file" option
step 5. "view/edit" /mywebsite/live.myweb/web.config and close or leave it there.
step 6. Switch to FZ. Then it will prompt "File has changed" dialog. But this time it shows...
Filename: web.config (instead of "web 2.config" as it normally does.)
Remote path: /mywebsite/dev.myweb (this should be "/mywebsite/live.myweb")
If I choose "Yes" it will replace the web.config in "dev.myweb" with web.config of "live.myweb"

(Please do not miss details. In my previous post, I mentioned that I'm using Notepad but you seem to miss that.)

  Changed 5 years ago by codesquid

  • status changed from new to moreinfo

I still cannot reproduce this, I even used the exact same paths and filenames.

How are the files .config files associated with Notepad? Is it a system setting or is the editor set to Notepad in FileZilla?

  Changed 5 years ago by sudarsh

  • status changed from moreinfo to new

The editor is set to Notepad in FileZilla.

(The server physical path is "E:\hshome\mywebsite")
Note: I do not have the issue on a different server.

  Changed 5 years ago by codesquid

  • status changed from new to moreinfo

Just Notepad? No .exe suffix? path to the executable?

Since it only happens with that server, can you please attach some logs?

  Changed 5 years ago by sudarsh

  • status changed from moreinfo to new

setting is
Use Custom Editor
value is
C:\WINDOWS\notepad.exe

~Log~
Status: Resolving address of win2.xxxxx.com
Status: Connecting to xx.xxx.xxx.xxx:21...
Status: Connection established, waiting for welcome message...
Response: 220 Microsoft FTP Service
Command: USER jackryan
Response: 331 Password required for mywebsite.
Command: PASS ********
Response: 230 User mywebsite logged in.
Command: SYST
Response: 215 Windows_NT
Command: FEAT
Response: 211-FEAT
Response: SIZE
Response: MDTM
Response: 211 END
Status: Connected
Status: Retrieving directory listing...
Command: PWD
Response: 257 "/mywebsite" is current directory.
Command: TYPE I
Response: 200 Type set to I.
Command: PASV
Response: 227 Entering Passive Mode (xx.xxx.xxx.xxx,5,135).
Command: LIST
Response: 125 Data connection already open; Transfer starting.
Response: 226 Transfer complete.
Status: Directory listing successful
Status: Retrieving directory listing...
Command: CWD dev.mywebsitename.com
Response: 250 CWD command successful.
Command: PWD
Response: 257 "/mywebsite/dev.mywebsitename.com" is current directory.
Command: PASV
Response: 227 Entering Passive Mode (xx.xxx.xxx.xxx,5,136).
Command: LIST
Response: 125 Data connection already open; Transfer starting.
Response: 226 Transfer complete.
Status: Directory listing successful
Status: Resolving address of win2.xxxxx.com
Status: Connecting to xx.xxx.xxx.xxx:21...
Status: Connection established, waiting for welcome message...
Response: 220 Microsoft FTP Service
Command: USER mywebsite
Response: 331 Password required for mywebsite.
Command: PASS ********
Response: 230 User mywebsite logged in.
Status: Connected
Status: Starting download of /mywebsite/dev.mywebsitename.com/Web.Config
Command: CWD /mywebsite/dev.mywebsitename.com
Response: 250 CWD command successful.
Command: PWD
Response: 257 "/mywebsite/dev.mywebsitename.com" is current directory.
Command: TYPE I
Response: 200 Type set to I.
Command: PASV
Response: 227 Entering Passive Mode (xx.xxx.xxx.xxx,5,137).
Command: RETR Web.Config
Response: 125 Data connection already open; Transfer starting.
Response: 226 Transfer complete.
Status: File transfer successful
Status: Starting upload of C:\Documents and Settings\myname\Local Settings\Temp\fz3temp-1\Web.Config
Command: PASV
Response: 227 Entering Passive Mode (xx.xxx.xxx.xxx,5,138).
Command: STOR Web.Config
Response: 125 Data connection already open; Transfer starting.
Response: 226 Transfer complete.
Status: File transfer successful
Status: Retrieving directory listing...
Command: CWD /mywebsite/myapp.mywebsitename.com
Response: 250 CWD command successful.
Command: PWD
Response: 257 "/mywebsite/myapp.mywebsitename.com" is current directory.
Command: PASV
Response: 227 Entering Passive Mode (xx.xxx.xxx.xxx,5,146).
Command: LIST
Response: 125 Data connection already open; Transfer starting.
Response: 226 Transfer complete.
Status: Directory listing successful
Status: Starting download of /mywebsite/myapp.mywebsitename.com/web.config
Command: CWD /mywebsite/myapp.mywebsitename.com
Response: 250 CWD command successful.
Command: PASV
Response: 227 Entering Passive Mode (xx.xxx.xxx.xxx,5,147).
Command: RETR web.config
Response: 125 Data connection already open; Transfer starting.
Response: 226 Transfer complete.
Status: File transfer successful

  Changed 5 years ago by codesquid

  • status changed from new to moreinfo

Are there any third party programs or services running that are not officially part of Windows? (in other words not on retail Windows XP CD-ROM nor windowsupdate).

What happens if you terminate all those programs? (Uninstall if needed, such as firewalls and virus scanners)

  Changed 5 years ago by sudarsh

  • status changed from moreinfo to new

Yes, there are many.
Sorry, I can't unstall them. I'm on my office system.

I have the following apps.
Symantec Client Security
Visual Studio 2003
Visual Studio 2005
Office 2003
Spybot
AOL Messenger
Skype
Paint.NET

and many more.

(But I believe it is some other issue as I already said, I do not have the issue with a different server)

  Changed 5 years ago by codesquid

  • status changed from new to moreinfo

#4537 is another ticket with similar symptoms.

The key to reproduce that other bug is the specific way how to return into FileZilla from the editor.

Are you doing it the same way?

  Changed 5 years ago by sudarsh

  • status changed from moreinfo to new

Not exactly. I use windows taskbar to select FileZilla window. I'll get the latest version and will check if it is fixed or not and let you know.

  Changed 5 years ago by kelye

I can confirm the bug.
Win XP SP3, Filezilla client 3.2.4.1, Scite editor as default editor for php files

If i edit /webroot/index.php and after open/edit /webroot/subfolder/index.php my initial /webroot/index.php is overwritten (i am asked if i want to update but twice , and the first time is for the old file)

the problem seems to be with the directory where the local copy is stored (Document and settings(...)/Temp/fz3temp-1/index.php )

  Changed 5 years ago by tvdiepen

I can confirm this bug, it seems to happen when you use different upper/lower case characters. For example:

after editing /map1/menu.php, filezilla shows one new upload window.
after editing /map2/Menu.php, filezilla shows two upload windows, one for menu.php and one for Menu.php. Where you will usually overwrite your Menu.php with the menu.php file.

Filezilla client 3.2.7.1 on Win XP

  Changed 5 years ago by codesquid

  • status changed from new to closed
  • resolution set to fixed

Duplicate of #4803, will be fixed in the next version.

Note: See TracTickets for help on using tickets.