Ticket #3922 (closed Bug report: fixed)

Opened 5 years ago

Last modified 5 years ago

Regardless of the /S switch, the NSIS installer displays an error dialog box in case of error.

Reported by: deployguy Owned by:
Priority: normal Component: FileZilla Client
Keywords: silent installer deployment Cc:
Operating system type: Windows Operating system version: XP

Description

The silent installation mode is used for deployments to hundred or thousand machines with tools like SMS/SCCM, Tivoli, etc.

Example : FileZilla_3.1.5_win32-setup.exe /S /user=all

But currently when there is an installation error, the installation script displays a message box like "Unsupported operating system...", "Cannot install for all users...", etc.

The problem is that with this kind of deployment the user cannot even see the dialog box because the installation is made through the network in a "no-display" context, wether or not the user is logged on.
So the installation process is stuck until the next reboot and the failure is not detected by the deployment tool.

I am not an NSIS expert but it seems that adding "/SD IDOK" or "/SD IDNO" to each "MessageBox" line in the installation script would fix the problem.

It would be nice also to always create an installation log file so that installation errors could be easily managed.

Thanks.

Change History

Changed 5 years ago by codesquid

  • status changed from new to closed
  • resolution set to fixed

Will be fixed in the next version.

Note: See TracTickets for help on using tickets.