Opened 6 years ago

Closed 6 years ago

#9394 closed Bug report (invalid)

Filezilla does not load

Reported by: Larry McClellan Owned by:
Priority: normal Component: FileZilla Client
Keywords: relocation error Cc: drt781@…
Component version: Operating system type: Linux
Operating system version: openSUSE 13.1 (Bottle) (x86_64)

Description

filezilla -v
filezilla: relocation error: filezilla: symbol _ZTV10wxListBase, version WXU_2.8 not defined in file libwx_baseu-2.8.so.0 with link time reference

filezilla version installed: 3.7.3-40.1

uname -a
Linux bigtux 3.11.10-7-desktop #1 SMP PREEMPT Mon Feb 3 09:41:24 UTC 2014 (750023e) x86_64 x86_64 x86_64 GNU/Linux

Linux 3.11.10-7-desktop
openSUSE 13.1 (Bottle) (x86_64)

Change History (3)

comment:1 Changed 6 years ago by Alexander Schuch

Status: newmoreinfo

Did you install FileZilla via package or did you compile from source? Did you install wxWidgets via package or did you compile from source? Which version of wxWidgets is installed?

comment:2 in reply to:  1 Changed 6 years ago by drt781@…

Cc: drt781@… added
Status: moreinfonew

Had same problem, also OpenSuse 13.1. Resolved by installing development versions of libwx marked as 2_9 ... which forced downgrade of FileZilla to 3.7.3-2.1.2.i586 , which appears to work. All packages are from standard repos.

Replying to ci-dev:

Did you install FileZilla via package or did you compile from source? Did you install wxWidgets via package or did you compile from source? Which version of wxWidgets is installed?


comment:3 Changed 6 years ago by Alexander Schuch

Resolution: invalid
Status: newclosed

If you just installed FileZilla and wxWidgets via packages, you should file a bug report against the OpenSuSE package repository. Compiling FileZilla from source just works against a recent version of wxWidgets 2.8.

Note: See TracTickets for help on using tickets.