Opened 11 years ago

Closed 5 years ago

#5085 closed Bug report (fixed)

time for to in speed limits lost after reboot — at Version 5

Reported by: pjsat Owned by:
Priority: normal Component: FileZilla Server
Keywords: time speed limit not saved Cc:
Component version: Operating system type: Windows
Operating system version: Windows XP

Description (last modified by Tim Kosse)

When setting speed limits at particular times, it is not being written to the xml file properly under Win7 64 bit

e.g. <SpeedLimits DlType="3" DlLimit="10" ServerDlLimitBypass="1" UlType="0" UlLimit="10" ServerUlLimitBypass="1">
<Download>
<Rule Speed="25" Hour="6" Minute="0" Second="0">
<Days>127</Days>
<From />
<To />
</Rule>
<Rule Speed="12" Hour="23" Minute="0" Second="0">
<Days>127</Days>
<From />
<To />
</Rule>
</Download>
<Upload />
</SpeedLimits>

As soon as the server is restated it loses the times you set the limits at.

Same on 9.33 and 9.34.

Change History (5)

comment:1 by pjsat, 11 years ago

That's when setting the times through the server interface.
Also tried running server interface as "run as admin", made no difference.

comment:2 by pjsat, 11 years ago

Should be written like this>

<SpeedLimits DlType="3" DlLimit="10" ServerDlLimitBypass="1" UlType="0" UlLimit="10" ServerUlLimitBypass="1">

<Download>

<Rule Speed="25">

<Days>127</Days>
<From Hour="21" Minute="00" Second="00" />
<To Hour="06" Minute="00" Second="00" />

</Rule>
<Rule Speed="12">

<Days>127</Days>
<From Hour="06" Minute="00" Second="00" />
<To Hour="21" Minute="00" Second="00" />

</Rule>

</Download>
<Upload />

</SpeedLimits>

comment:3 by David, 11 years ago

Keywords: speed limit W7 64bits added
Operating system version: Win7 64 bit ultWindows 7 64bits
Summary: Setting speed limits at certain timesSetting speed limits clear after reboot W7 64bits

same problem, with Windows7 64bits.

same result in XML file.

comment:4 by David, 11 years ago

Keywords: time not saved added; W7 64bits removed
Operating system version: Windows 7 64bitsWindows XP
Summary: Setting speed limits clear after reboot W7 64bitstime for to in speed limits lost after reboot

same problem with Windows XP, same error in XML
after restart, time to and time for is lost.

comment:5 by Tim Kosse, 5 years ago

Description: modified (diff)
Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.