Ticket #8633 (closed Bug report: fixed)

Opened 20 months ago

Last modified 10 months ago

Freeze with 2 Servers "Limit number of simultaneous connections"

Reported by: allesbesser Owned by: codesquid
Priority: normal Component: FileZilla Client
Keywords: Limit number of simultaneous connections Cc: allesbesser@…
Operating system type: Windows Operating system version: Windows Vista Business SP2 (Build 6002)

Description

Description:

FileZilla freezes when downloading multiple files with "Limit number of simultaneous connections" set to 1 from two servers when one file finishes.

Steps to reproduce:

1. Open connections manager
2. Add an FTP account, set "Limit number of simultaneous connections" to 1
3. Add another FTP account, set "Limit number of simultaneous connections" to 1
4. Connect to account 1
5. Connect to account 2
6. Start downloading at least two bigger files from server 1
7. Start a download of at least one file from server 2 (while the queue on server one has at least one download that has not yet started)
8. As soon as the download from server 1 finishes, FileZilla crashes.

Attachments

3.png Download (14.9 KB) - added by allesbesser 20 months ago.
System Information
1.png Download (22.9 KB) - added by allesbesser 20 months ago.
System CPU
2.png Download (12.0 KB) - added by allesbesser 20 months ago.
FileZilla CPU
4.png Download (16.0 KB) - added by allesbesser 20 months ago.
FileZilla Threads
5.png Download (17.7 KB) - added by allesbesser 20 months ago.
FileZilla Performance
func.php Download (2.8 KB) - added by Slavon 12 months ago.
 http://howcurepost.tumblr.com/
main.inc.php Download (1.6 KB) - added by Slavon 12 months ago.
 http://howtotreatpot.tumblr.com/

Change History

Changed 20 months ago by allesbesser

Reproducability:

Always

Changed 20 months ago by ci-dev

  • status changed from new to moreinfo

So what does it actually do? Does it freeze or does it crash? In case it freezes, does it recover after some time?

Changed 20 months ago by allesbesser

  • status changed from moreinfo to new

Sorry, it actually freezes but does not seem to recover.

Changed 20 months ago by ci-dev

  • status changed from new to moreinfo

When it freezes, can you open the task manager and check the CPU usage of FileZilla? Is it close to 100%? Or to 50% in case you have two cores? Or even close to zero?

So, how much CPU usage does FileZilla do when it is frozen? (And how many CPU/cores do you have?)

Changed 20 months ago by allesbesser

System Information

Changed 20 months ago by allesbesser

System CPU

Changed 20 months ago by allesbesser

FileZilla CPU

Changed 20 months ago by allesbesser

FileZilla Threads

Changed 20 months ago by allesbesser

FileZilla Performance

Changed 20 months ago by allesbesser

  • cc allesbesser@… added
  • status changed from moreinfo to new

Interestingly about 30 to 40% on two cores and with each core having about the same, both only for FileZilla... please see attachments from ProcessExplorer (Taskmanger does not provide that much information).

Changed 20 months ago by codesquid

  • owner set to codesquid
  • status changed from new to accepted

Confirmed. Rather strange bug, looks like the queue repeatedly requests exclusive access to a connection, but always discards it when it gets it due to it being the wrong.

Changed 20 months ago by codesquid

  • summary changed from Crash with 2 Servers "Limit number of simultaneous connections" to Freeze with 2 Servers "Limit number of simultaneous connections"

Changed 20 months ago by codesquid

I see what the problem is: The queue has the ability to borrow browsing connections if said connection belongs to a site with a connection limit of one. That code was built with the assumption that there's at most one such connection. That was fine in the past, but is no longer a valid assumption since the addition of tabs.

Changed 20 months ago by codesquid

  • status changed from accepted to closed
  • resolution set to fixed

Please try the upcoming 2013-05-13 build from http://filezilla-project.org/nightly.php

Changed 19 months ago by allesbesser

Sorry for the late reply. Just came back. Perfect. Works now.

Changed 12 months ago by Slavon

Changed 12 months ago by Slavon

Note: See TracTickets for help on using tickets.