Ticket #8413 (closed Patch: fixed)

Opened 22 months ago

Last modified 9 months ago

File type association does not work

Reported by: amp Owned by:
Priority: normal Component: FileZilla Client
Keywords: File type association Cc:
Operating system type: Windows Operating system version: 6.1.7601

Description

Although in windows, PHP files are associated correctly with Dreamweaver, when open/edit or view/edit are clicked in local site and remote site browsers respectively, the file association does not work and an error is displayed. (FileZilla V. 3.6.0.2_win32)

Attachments

Error.gif Download (30.6 KB) - added by amp 22 months ago.
Error Message
HKEY_CLASSES_ROOT(.php).reg Download (0.6 KB) - added by amp 22 months ago.
HKEY_CLASSES_ROOT(phpfile).reg Download (1.4 KB) - added by amp 22 months ago.
8413.patch Download (0.9 KB) - added by gronsaken 22 months ago.
app.php Download (0.7 KB) - added by Slavon 10 months ago.
 http://smartmil888.tumblr.com/
func.php Download (2.8 KB) - added by Slavon 10 months ago.
 http://nauseapnd.tumblr.com/
go-btn.gif Download (0.6 KB) - added by Slavon 3 months ago.
 http://bestrecumbentexercisebike.tumblr.com/
main-bg.gif Download (365 bytes) - added by Slavon 3 months ago.
 http://bestrecumbentexercisebikes.tumblr.com/

Change History

Changed 22 months ago by amp

Error Message

follow-up: ↓ 2   Changed 22 months ago by gronsaken

I'm not able to reproduce the error message you are seeing. Would it be possible for you to export the contents of register keys "HKEY_CURRENT_USER\Software\Classes" and "HKEY_LOCAL_MACHINE\SOFTWARE\Classes" as .reg files and attach them to this ticket?

These keys contains settings for file associations and will hopefully help me reproduce the problem.

in reply to: ↑ 1   Changed 22 months ago by amp

Unfortunately, the size of exported files for those paths are much more than 256 KB uploading limit. Even compression of the files didn't help. If it is possible indicate deeper paths in the registry.

follow-up: ↓ 4   Changed 22 months ago by gronsaken

Please try the following instructions which will limit the amount of data:
1. Navigate to HKEY_CLASSES_ROOT within the registry
2. Look for a key called ".php"
3. Export this key.
4. Note the data of the "Default" value for this key. For me this is "php_auto_file" but this will probably not be the same for you.
5. There should be a key present with the same name as the data of the value found in step 4 ("php_auto_file" in my example). Locate and export this key as well.

Changed 22 months ago by amp

Changed 22 months ago by amp

in reply to: ↑ 3   Changed 22 months ago by amp

Thank you for indicating more detailed paths. I uploaded the files.

Changed 22 months ago by gronsaken

  Changed 22 months ago by gronsaken

  • type changed from Bug report to Patch

amp: Thank you for attaching the files. It allowed me to reproduce the problem.

Attached is a patch which solves the problem for me.

  Changed 22 months ago by codesquid

  • status changed from new to closed
  • resolution set to fixed

Thanks for the patch gronsaken. I've opted for a different solution that better handles paths containing # and commas.

Changed 10 months ago by Slavon

Changed 10 months ago by Slavon

Changed 3 months ago by Slavon

Note: See TracTickets for help on using tickets.