Ticket #5474 (accepted Bug report)

Opened 4 years ago

Last modified 9 months ago

Connection Time out; file transfer failed

Reported by: spineofsteel Owned by: Charon77
Priority: normal Component: FileZilla Client
Keywords: Time out Cc: mikoletic@…
Operating system type: Windows Operating system version: 7 x64

Description

Tried transferring two different files, both of which failed multiple times after transferring EXACTLY 393,216 bytes!
_
Error: Connection timed out
Error: File transfer failed after transferring 393,216 bytes in 24 seconds
_
Here is a full listing of my session:

Status: Resolving address of ftp.kinetic.more.net
Status: Connecting to 198.209.253.55:21...
Status: Connection established, waiting for welcome message...
Response: 220 ProFTPD 1.3.3 Server (kinetic Service) [198.209.253.55]
Command: USER bethmen@…
Response: 331 Password required for bethmen@…
Command: PASS ********
Response: 230 User bethmen@… logged in
Command: SYST
Response: 215 UNIX Type: L8
Command: FEAT
Response: 550 FEAT: Operation not permitted
Status: Connected
Status: Retrieving directory listing...
Command: CWD /export/kinetic/home/c/coin.org/bbb/eee/bethmen/WebPublish/bethelmennchurch.org/www
Response: 250 CWD command successful
Command: PWD
Response: 257 "/export/kinetic/home/c/coin.org/bbb/eee/bethmen/WebPublish/bethelmennchurch.org/www" is the current directory
Command: TYPE I
Response: 200 Type set to I
Command: PASV
Response: 227 Entering Passive Mode (198,209,253,55,202,22).
Command: LIST
Response: 150 Opening BINARY mode data connection for file list
Response: 226 Transfer complete
Status: Directory listing successful
Status: Resolving address of ftp.kinetic.more.net
Status: Connecting to 198.209.253.55:21...
Status: Connection established, waiting for welcome message...
Response: 220 ProFTPD 1.3.3 Server (kinetic Service) [198.209.253.55]
Command: USER bethmen@…
Response: 331 Password required for bethmen@…
Command: PASS ********
Response: 230 User bethmen@… logged in
Status: Connected
Status: Starting upload of Y:\Bethel Mennonite Church\Sermon Archive\2010\2010-07-18Message.mp3
Command: CWD /export/kinetic/home/c/coin.org/bbb/eee/bethmen/WebPublish/bethelmennchurch.org/www/Images
Response: 250 CWD command successful
Command: PWD
Response: 257 "/export/kinetic/home/c/coin.org/bbb/eee/bethmen/WebPublish/bethelmennchurch.org/www/Images" is the current directory
Status: Retrieving directory listing...
Command: TYPE I
Response: 200 Type set to I
Command: PASV
Response: 227 Entering Passive Mode (198,209,253,55,223,81).
Command: LIST
Response: 150 Opening BINARY mode data connection for file list
Response: 226 Transfer complete
Command: PASV
Response: 227 Entering Passive Mode (198,209,253,55,204,179).
Command: STOR 2010-07-18Message.mp3
Response: 150 Opening BINARY mode data connection for 2010-07-18Message.mp3
Error: Connection timed out
Error: File transfer failed after transferring 393,216 bytes in 23 seconds
Status: Resolving address of ftp.kinetic.more.net
Status: Connecting to 198.209.253.55:21...
Status: Connection established, waiting for welcome message...
Response: 220 ProFTPD 1.3.3 Server (kinetic Service) [198.209.253.55]
Command: USER bethmen@…
Response: 331 Password required for bethmen@…
Command: PASS ********
Response: 230 User bethmen@… logged in
Status: Connected
Status: Starting upload of Y:\Bethel Mennonite Church\Sermon Archive\2010\2010-07-18Message.mp3
Command: CWD /export/kinetic/home/c/coin.org/bbb/eee/bethmen/WebPublish/bethelmennchurch.org/www/Images
Response: 250 CWD command successful
Status: Retrieving directory listing...
Command: TYPE I
Response: 200 Type set to I
Command: PASV
Response: 227 Entering Passive Mode (198,209,253,55,209,206).
Command: LIST
Response: 150 Opening BINARY mode data connection for file list
Response: 226 Transfer complete
Command: PASV
Response: 227 Entering Passive Mode (198,209,253,55,224,211).
Command: APPE 2010-07-18Message.mp3
Response: 451 2010-07-18Message.mp3: Append/Restart not permitted, try again
Error: File transfer failed
Status: Starting upload of Y:\Bethel Mennonite Church\Sermon Archive\2010\2010-07-18Message.mp3
Status: Retrieving directory listing...
Command: PASV
Response: 227 Entering Passive Mode (198,209,253,55,233,6).
Command: LIST
Response: 150 Opening BINARY mode data connection for file list
Response: 226 Transfer complete
Status: Skipping upload of Y:\Bethel Mennonite Church\Sermon Archive\2010\2010-07-18Message.mp3
Status: File transfer successful, transferred 3,836 bytes in 3 seconds
Status: Retrieving directory listing...
Command: CWD Images
Response: 250 CWD command successful
Command: PWD
Response: 257 "/export/kinetic/home/c/coin.org/bbb/eee/bethmen/WebPublish/bethelmennchurch.org/www/Images" is the current directory
Status: Directory listing successful
Command: DELE 2010-07-18Message.mp3
Response: 250 DELE command successful
Status: Disconnected from server
Status: Resolving address of ftp.kinetic.more.net
Status: Connecting to 198.209.253.55:21...
Status: Connection established, waiting for welcome message...
Response: 220 ProFTPD 1.3.3 Server (kinetic Service) [198.209.253.55]
Command: USER bethmen@…
Response: 331 Password required for bethmen@…
Command: PASS ********
Response: 230 User bethmen@… logged in
Status: Connected
Status: Starting upload of Y:\Bethel Mennonite Church\Sermon Archive\2010\2010-07-18Message.mp3
Command: CWD /export/kinetic/home/c/coin.org/bbb/eee/bethmen/WebPublish/bethelmennchurch.org/www/Images
Response: 250 CWD command successful
Command: TYPE I
Response: 200 Type set to I
Command: PASV
Response: 227 Entering Passive Mode (198,209,253,55,249,220).
Command: STOR 2010-07-18Message.mp3
Response: 150 Opening BINARY mode data connection for 2010-07-18Message.mp3
Error: Connection timed out
Error: File transfer failed after transferring 393,216 bytes in 24 seconds
Status: Resolving address of ftp.kinetic.more.net
Status: Connecting to 198.209.253.55:21...
Status: Connection established, waiting for welcome message...
Response: 220 ProFTPD 1.3.3 Server (kinetic Service) [198.209.253.55]
Command: USER bethmen@…
Response: 331 Password required for bethmen@…
Command: PASS ********
Response: 230 User bethmen@… logged in
Status: Connected
Status: Starting upload of Y:\Bethel Mennonite Church\Sermon Archive\2010\2010-07-18Message.mp3
Command: CWD /export/kinetic/home/c/coin.org/bbb/eee/bethmen/WebPublish/bethelmennchurch.org/www/Images
Response: 250 CWD command successful
Status: Retrieving directory listing...
Command: TYPE I
Response: 200 Type set to I
Command: PASV
Response: 227 Entering Passive Mode (198,209,253,55,252,112).
Command: LIST
Response: 150 Opening BINARY mode data connection for file list
Response: 226 Transfer complete
Command: PASV
Response: 227 Entering Passive Mode (198,209,253,55,251,210).
Command: APPE 2010-07-18Message.mp3
Response: 451 2010-07-18Message.mp3: Append/Restart not permitted, try again
Error: File transfer failed
Status: Starting upload of Y:\Bethel Mennonite Church\Sermon Archive\2010\2010-07-18Message.mp3
Status: Retrieving directory listing...
Command: PASV
Response: 227 Entering Passive Mode (198,209,253,55,222,163).
Command: LIST
Response: 150 Opening BINARY mode data connection for file list
Response: 226 Transfer complete
Status: Skipping upload of Y:\Bethel Mennonite Church\Sermon Archive\2010\2010-07-18Message.mp3
Status: File transfer successful, transferred 3,836 bytes in 2 seconds
Status: Starting upload of Y:\Bethel Mennonite Church\Bulletins\2010\PDF\2010-07-18_BMC_Bulletin.pdf
Command: PASV
Response: 227 Entering Passive Mode (198,209,253,55,213,230).
Command: STOR 2010-07-18_BMC_Bulletin.pdf
Response: 150 Opening BINARY mode data connection for 2010-07-18_BMC_Bulletin.pdf
Error: Connection timed out
Error: File transfer failed after transferring 393,216 bytes in 23 seconds
Status: Resolving address of ftp.kinetic.more.net
Status: Connecting to 198.209.253.55:21...
Status: Connection established, waiting for welcome message...
Response: 220 ProFTPD 1.3.3 Server (kinetic Service) [198.209.253.55]
Command: USER bethmen@…
Response: 331 Password required for bethmen@…
Command: PASS ********
Response: 230 User bethmen@… logged in
Status: Connected
Status: Starting upload of Y:\Bethel Mennonite Church\Bulletins\2010\PDF\2010-07-18_BMC_Bulletin.pdf
Command: CWD /export/kinetic/home/c/coin.org/bbb/eee/bethmen/WebPublish/bethelmennchurch.org/www/Images
Response: 250 CWD command successful
Status: Retrieving directory listing...
Command: TYPE I
Response: 200 Type set to I
Command: PASV
Response: 227 Entering Passive Mode (198,209,253,55,239,160).
Command: LIST
Response: 150 Opening BINARY mode data connection for file list
Response: 226 Transfer complete
Command: PASV
Response: 227 Entering Passive Mode (198,209,253,55,225,46).
Command: APPE 2010-07-18_BMC_Bulletin.pdf
Response: 451 2010-07-18_BMC_Bulletin.pdf: Append/Restart not permitted, try again
Error: File transfer failed
Status: Starting upload of Y:\Bethel Mennonite Church\Bulletins\2010\PDF\2010-07-18_BMC_Bulletin.pdf
Status: Retrieving directory listing...
Command: PASV
Response: 227 Entering Passive Mode (198,209,253,55,253,86).
Command: LIST
Response: 150 Opening BINARY mode data connection for file list
Response: 226 Transfer complete
Status: Skipping upload of Y:\Bethel Mennonite Church\Bulletins\2010\PDF\2010-07-18_BMC_Bulletin.pdf
Status: File transfer successful, transferred 3,928 bytes in 3 seconds
Status: Disconnected from server

Change History

  Changed 4 years ago by codesquid

  • status changed from new to closed
  • resolution set to worksforme

Could either be a full disk on server or some router and/or firewall blocking FileZilla.

Contact the server administrator about the first possibility. To rule out the second, uninstall all firewalls between the client and the server and plug your computer directory into your modem, thus bypassing all consumer-grade routers.

  Changed 4 years ago by mikoletic87

  • cc mikoletic@… added
  • status changed from closed to reopened
  • priority changed from normal to high
  • resolution worksforme deleted
  • type changed from Bug report to Patch

hi i think i solve this problem, sory for my english but i hope so i help wit this:

open your FZ, then go menu edit/settings.../ and here set Time out in seconds to :500 sec;

its work now for me because we have slow upload and if file dont uploud for 20 sec the conecion will be closed by FZ.

best wishes and always try to read documetns about program what you use !!! see ya

  Changed 3 years ago by Sworddragon

  • status changed from accepted to assigned
  • os changed from BSD to Windows
  • component changed from Other to FileZilla Client
  • summary changed from FILEZILLA SMELLS LIKE FISH to Connection Time out
  • os_version changed from FILEZILLA SMELLS LIKE FISH to XP Service Pack 3
  • keywords Time out added; FILEZILLA SMELLS LIKE FISH removed
  • owner troll deleted
  • type changed from Feature request to Patch

  Changed 3 years ago by codesquid

  • type changed from Patch to Bug report

  Changed 21 months ago by Charon77

  • owner set to Charon77
  • status changed from reopened to accepted

This does happen on misconfigured server. I will try my best to fix it.

  Changed 20 months ago by ci-dev

  • priority changed from high to normal
  • status changed from accepted to moreinfo_accepted

@Charon77:

What do you want to do? The op seem to have fixed his issue.

  Changed 20 months ago by Charon77

@ci-dev
Thing is, I got the same problem, and I don't think I should start a new thread. I could be wrong though.
OP's solution does not work for me

  Changed 20 months ago by ci-dev

  • status changed from moreinfo_accepted to accepted

Oh. I thought you want to write a patch for FileZilla Client. If you have more information regarding this problem (as you can reproduce it), please elaborate.

  Changed 20 months ago by Charon77

I was kinda working on a patch, but nothing works for me, as my knowledge on the code are limited.
Yes, I can still reproduce the problem easily.

I made a web hosting at  http://www.freehostingeu.com/
Then I simply upload a large file. (27MB)
It always stops at about 70+ seconds, and restarts at 0.

There is a temporary solution:
1. Upload the file
2. Stop (Pause) before it reaches the 70+ seconds
3. Resume

This trick does 'work', but really an ineffective way.
I use FZ 3.6.0.2 Win x64

follow-up: ↓ 13   Changed 13 months ago by ci-dev

  • status changed from accepted to moreinfo_accepted

@Charon77:

Do you still have that issue or is the problem solved for you now?

in reply to: ↑ 12   Changed 13 months ago by Charon77

  • os_version changed from XP Service Pack 3 to 7 x64

Replying to ci-dev:

@Charon77:

Do you still have that issue or is the problem solved for you now?

Hi, still haven't solved the problem...

  Changed 13 months ago by ci-dev

  • status changed from moreinfo_accepted to accepted
Note: See TracTickets for help on using tickets.