Ticket #4847 (closed Bug report: fixed)

Opened 5 years ago

Last modified 4 years ago

program crashes

Reported by: maciek_s Owned by:
Priority: normal Component: FileZilla Client
Keywords: maciek Cc:
Operating system type: Windows Operating system version: XP 32

Description

FileZilla Client crashes after program starting. The last version that works is 3.2.6.1

Attachments

ce3b_appcompat.txt Download (10.1 KB) - added by maciek_s 5 years ago.
capture.pcap Download (5.0 KB) - added by maciek_s 5 years ago.
capture_2.pcap Download (4.7 KB) - added by maciek_s 5 years ago.
filezilla.log Download (1.5 KB) - added by maciek_s 5 years ago.
log.txt Download (27.3 KB) - added by maciek_s 5 years ago.
filezilla.2.log Download (40.6 KB) - added by maciek_s 5 years ago.
filezilla3.log Download (40.8 KB) - added by maciek_s 5 years ago.
filezilla4.log Download (45.7 KB) - added by maciek_s 5 years ago.

Change History

Changed 5 years ago by maciek_s

  Changed 5 years ago by maciek_s

  • summary changed from maciek_s@o2.pl to program crashes

follow-up: ↓ 3   Changed 5 years ago by codesquid

  • status changed from new to moreinfo

Please try a fresh, fully patched Windows installation with no third-party software installed.

in reply to: ↑ 2 ; follow-up: ↓ 4   Changed 5 years ago by maciek_s

  • status changed from moreinfo to new

I'm sorry, I can't reinstall system on my computer.
Replying to codesquid:

Please try a fresh, fully patched Windows installation with no third-party software installed.

in reply to: ↑ 3   Changed 5 years ago by maciek_s

FileZilla Client 3.2.8.1 now works, but crashes, when I try to "Check for updates..."

  Changed 5 years ago by codesquid

  • status changed from new to moreinfo

I think there's something wrong with your system.

Try stopping, or better uninstalling, all third-party programs.

  Changed 5 years ago by maciek_s

  • status changed from moreinfo to new

I started Windows in "safe mode". Problem still exists - program works fine, but crashes, when I try to check for updates.

  Changed 5 years ago by codesquid

  • status changed from new to moreinfo

Please install Wireshark and create a package dump when trying to start FileZilla.

It'll contain all data FileZilla sends and receives during the update check. That should help to narrow the problem down.

Changed 5 years ago by maciek_s

  Changed 5 years ago by maciek_s

  • status changed from moreinfo to new

I hope, I've made it properly :-)

follow-up: ↓ 10   Changed 5 years ago by codesquid

  • status changed from new to moreinfo

Which language are you using FileZilla in? What happens if you delete the locales subdirectory in FileZilla's installation directory?

in reply to: ↑ 9   Changed 5 years ago by maciek_s

  • status changed from moreinfo to new

I'm using polish language. After deleting locales subdirectory FileZilla starts in english. The situation is the same - program works fine until I try to check for updates.

Changed 5 years ago by maciek_s

  Changed 5 years ago by codesquid

  • status changed from new to moreinfo

Sadly not helpful, nothing unusual in the package dump, everything looks in order.

Please try the following:
- Set debug level to 4 on the settings dialog of FileZilla
- Enable logging to file on the logging page in the settings dialog
- Restart FileZilla
- Make it crash

Please attach the resulting log file.

Changed 5 years ago by maciek_s

  Changed 5 years ago by maciek_s

  • status changed from moreinfo to new

I've made something else. I've deleted FileZilla folder from Application data folder. After this program crashes immediately after starting.

  Changed 5 years ago by codesquid

  • status changed from new to moreinfo

I wonder whether it might not be a bug in FileZilla but perhaps in GnuTLS, the used TLS library.

Please try the following:
- Download  http://josefsson.org/gnutls4win/gnutls-2.8.4.zip and extract to c:\gnutls
- Start cmd.exe
- Enter the following commands:

c:
cd \gnutls\bin
gnutls-cli -d 99 -p 443 update.filezilla-project.org > log.txt 2>&1

If it doesn't crash you can abort it with ctrl+c after about a minute or so. In either case, please attach log.txt to this ticket.

Changed 5 years ago by maciek_s

  Changed 5 years ago by maciek_s

  • status changed from moreinfo to new

It didn't crash.

  Changed 5 years ago by codesquid

I'm becoming quite clueless.

  Changed 5 years ago by maciek_s

I use FileZilla on notebook HP Mini 2133. I'll try FileZilla on another computer (my brother has the same model).

  Changed 5 years ago by codesquid

  • status changed from new to moreinfo

Please try this special build of FileZilla, it includes A LOT of additional logging: http://filezilla-project.org/codesquid/temp/filezilla.exe

Since you deleted your %APPDATA%\FileZilla directory you might be unable to set debug level to 4 and to enable logging to file, in that case please copy http://filezilla-project.org/codesquid/temp/filezilla.xml to %APPDATA%\FileZilla\

Changed 5 years ago by maciek_s

  Changed 5 years ago by maciek_s

  • status changed from moreinfo to new

Here you are.

  Changed 5 years ago by codesquid

  • status changed from new to moreinfo

That proves that the issue is in fact something caused by GnuTLS or its dependencies, though I'm not sure yet why the gnutls-cli tool is not affected.

The log shows that it crashes somewhere inside the code that prepares and sends the TLS handshake finished confirmation, though it's not clear if it's the preparing or the sending that fails.

I've sprinkled GnuTLS with some additional debug code that will reveal this. Please make http://filezilla-project.org/codesquid/temp/filezilla2.exe crash and attach another log, it'll contain some additional information.

I really hope the problem is in fact in GnuTLS and not further down in libgcrypt, that would be extremely inconvenient.

Changed 5 years ago by maciek_s

  Changed 5 years ago by maciek_s

  • status changed from moreinfo to new

Here you are.

  Changed 5 years ago by codesquid

  • status changed from new to moreinfo

Getting closer. Next round: http://filezilla-project.org/codesquid/temp/filezilla3.exe

Also, I've noticed that HP Mini 2133 uses a very exotic processor, some Via C7-M [*] which appears to have some built-in crypto capabilities. Please try http://filezilla-project.org/codesquid/temp/hwcrypto_test.exe to check if it's used internally by libgcrypt.

[*] Remark: Personally I'll never ever buy anything from Via again, all their stuff I've ever used had severe stability issues.

  Changed 5 years ago by maciek_s

  • status changed from moreinfo to new

After runing hwcrypto_test.exe I've got "Result: 0 00000000"

Changed 5 years ago by maciek_s

  Changed 5 years ago by maciek_s

I've installed FileZilla on another HP Mini 2133. There is the same problem.

  Changed 5 years ago by codesquid

I suspect that the CPU instruction set might not be fully compatible to 586. Tomorrow I'll create a few builds of FileZilla trying out various compiler flags for the contained libgcrypt library.

  Changed 5 years ago by maciek_s

  • status changed from moreinfo to new

Two of them work and don't crash:
filezilla-nopadlock.exe
filezilla-noasm-nopadlock.exe

  Changed 5 years ago by codesquid

  • status changed from new to moreinfo

Great, at least there's a working workaround.

Now that Padlock support in libgrypt has been identified as the culprit, I could search the web for similar reports. I've found a related bug report:  https://bugs.launchpad.net/ubuntu/+source/libgcrypt11/+bug/389053

In the hopes that this is the very same problem I've applied the provided patch and created another build. Please try http://filezilla-project.org/codesquid/temp/filezilla-padlockfix.exe

  Changed 5 years ago by maciek_s

  • status changed from moreinfo to new

This build doesn't work at all and take 99% of procesor usage in task manager.

  Changed 5 years ago by codesquid

  • status changed from new to moreinfo

Oops, looks like some other unfinished code I've been working on accidentally made it into that build.
Please try http://filezilla-project.org/codesquid/temp/filezilla-padlockfix2.exe instead.

  Changed 5 years ago by maciek_s

  • status changed from moreinfo to new

This build crashes, like normal version (when trying to check for updates).

  Changed 5 years ago by codesquid

I think I'll just leave padlock support permanently disabled for the next version of FileZilla.

Without Padlock support TLS performance on Via CPUs will suffer, but then again right now it doesn't work at all.

  Changed 5 years ago by maciek_s

OK. Thank you! :-)

  Changed 4 years ago by maciek_s

  • status changed from new to closed
  • resolution set to fixed
Note: See TracTickets for help on using tickets.